Bug 109283 - [CSS Regions] Layout Test fast/regions/selecting-text-through-different-region-flows.html is failing
Summary: [CSS Regions] Layout Test fast/regions/selecting-text-through-different-regio...
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: AdobeTracked
Depends on: 119622
Blocks: 57312
  Show dependency treegraph
 
Reported: 2013-02-08 04:05 PST by Stephen Chenney
Modified: 2013-09-16 04:20 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen Chenney 2013-02-08 04:05:08 PST
The following layout test is failing on Mountain Lion.

fast/regions/selecting-text-through-different-region-flows.html

Probable cause: The cause is totally non obvious. We have a few of these, where a single pixel, or a few pixels, of text differ. I think the only solution is to have some allowed fuzziness.
Comment 1 Michelangelo De Simone 2013-06-13 11:35:11 PDT
Works for me on today's nightly (r151543)
Comment 2 Mihai Balan 2013-06-14 06:09:41 PDT
Reopening - we'd like to know when it got fixed and how.
Comment 3 Javier Fernandez 2013-08-13 14:24:59 PDT
This test was added by the fix for the bug 105641, which just avoided the clearing issues limiting the selection to the region boundaries.

I've proposed a new solution in the bug 119622, so perhaps adding a dependency on that bug would be a good idea.
Comment 4 Javier Fernandez 2013-09-12 15:16:30 PDT
Besides adding the dependency on bug 119622, which was already FIXED, I think we can close this bug as well.
Comment 5 Manuel Rego Casasnovas 2013-09-16 04:20:24 PDT
As explained in comment #3 and #4 the test is passing again.