Bug 108278 - webdatabase: Rename DBBackend::Server to DatabaseServer
Summary: webdatabase: Rename DBBackend::Server to DatabaseServer
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Mark Lam
Depends on:
Blocks: 107475
  Show dependency treegraph
Reported: 2013-01-29 18:28 PST by Mark Lam
Modified: 2013-01-29 20:08 PST (History)
6 users (show)

See Also:

the patch. (50.01 KB, patch)
2013-01-29 19:58 PST, Mark Lam
ggaren: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Lam 2013-01-29 18:28:32 PST
This is a sub-task of https://bugs.webkit.org/show_bug.cgi?id=107475.  Breaking out as a step for easier review.  This patch should be mostly a rename operation.  The only change other than a rename is to remove the DBBackend namespace (which has proven to be unhelpful so far in the refactoring effort).  Effectively, there are no semantic changes.
Comment 1 Mark Lam 2013-01-29 19:58:29 PST
Created attachment 185384 [details]
the patch.
Comment 2 Mark Lam 2013-01-29 20:00:01 PST
Comment on attachment 185384 [details]
the patch.

The patch looks good to me.  May I have a review please?  Thanks.
Comment 3 Geoffrey Garen 2013-01-29 20:02:07 PST
Comment on attachment 185384 [details]
the patch.

rs=me if it builds
Comment 4 Mark Lam 2013-01-29 20:08:40 PST
Landed in r141216: <http://trac.webkit.org/changeset/141216>.