Bug 107191 - REGRESSION (r139985): Full Screen Youtube loses keyboard and mouse control
Summary: REGRESSION (r139985): Full Screen Youtube loses keyboard and mouse control
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.8
: P1 Major
Assignee: Alexey Proskuryakov
URL: http://www.youtube.com/watch?v=h4IPm_...
Keywords: InRadar, Regression
: 107279 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-17 15:33 PST by Kevin M. Dean
Modified: 2013-01-18 16:56 PST (History)
3 users (show)

See Also:


Attachments
standalone fix (1.95 KB, patch)
2013-01-18 16:14 PST, Alexey Proskuryakov
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin M. Dean 2013-01-17 15:33:09 PST
Go to the link. Set the video to full screen and then don't move the mouse. Once the top title bar and the bottom control bars slide off, I can no longer press ESC to exit full screen, click to pause, move the mouse to see the cursor and bring back the top/bottom bars.

To get out, Command-TAB will get you out or if you select Webkit while Command-Tabbing you can quickly press ESC to get the video out of full screen.
Comment 1 Alexey Proskuryakov 2013-01-18 09:35:00 PST
*** Bug 107279 has been marked as a duplicate of this bug. ***
Comment 2 Alexey Proskuryakov 2013-01-18 09:46:31 PST
Oops, my fault.

Sam's refactoring in bug 107216 fixes this. Will mark as a duplicate once it's clear that it can be landed soon. Otherwise, I will just fix this regression.
Comment 3 Alexey Proskuryakov 2013-01-18 09:47:07 PST
<rdar://problem/13042826>
Comment 4 Alexey Proskuryakov 2013-01-18 16:14:35 PST
Created attachment 183568 [details]
standalone fix

Ok, Sam seems busy, so just fixing this issue.
Comment 5 Alexey Proskuryakov 2013-01-18 16:56:09 PST
Fixed in <http://trac.webkit.org/changeset/140220>.