Bug 106494 - Node::containingShadowRoot should be constant time
Summary: Node::containingShadowRoot should be constant time
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Elliott Sprehn
URL:
Keywords:
: 104342 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-09 14:49 PST by Elliott Sprehn
Modified: 2013-01-22 01:12 PST (History)
5 users (show)

See Also:


Attachments
Patch (1.55 KB, patch)
2013-01-09 14:52 PST, Elliott Sprehn
no flags Details | Formatted Diff | Diff
Patch (1.56 KB, patch)
2013-01-09 15:02 PST, Elliott Sprehn
no flags Details | Formatted Diff | Diff
Patch (1.56 KB, patch)
2013-01-09 15:05 PST, Elliott Sprehn
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Elliott Sprehn 2013-01-09 14:49:15 PST
Node::containingShadowRoot should be constant time
Comment 1 Elliott Sprehn 2013-01-09 14:52:50 PST
Created attachment 181990 [details]
Patch
Comment 2 Elliott Sprehn 2013-01-09 15:02:50 PST
Created attachment 181995 [details]
Patch
Comment 3 Elliott Sprehn 2013-01-09 15:05:02 PST
Created attachment 181996 [details]
Patch
Comment 4 Dimitri Glazkov (Google) 2013-01-09 15:36:51 PST
Comment on attachment 181996 [details]
Patch

<3
Comment 5 WebKit Review Bot 2013-01-09 18:53:22 PST
Comment on attachment 181996 [details]
Patch

Clearing flags on attachment: 181996

Committed r139273: <http://trac.webkit.org/changeset/139273>
Comment 6 WebKit Review Bot 2013-01-09 18:53:25 PST
All reviewed patches have been landed.  Closing bug.
Comment 7 Shinya Kawanaka 2013-01-22 01:12:00 PST
*** Bug 104342 has been marked as a duplicate of this bug. ***