Bug 10358 - Safari displays blank page, ice caps melt, people colonise mars, page loads
Summary: Safari displays blank page, ice caps melt, people colonise mars, page loads
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-11 23:41 PDT by Nicholas Shanks
Modified: 2007-02-08 18:07 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicholas Shanks 2006-08-11 23:41:07 PDT
Currently WebKit waits till it's loaded the page's CSS before displaying anything. I often find, for unknown reasons (perhaps DNS related) and often at times of high server load (e.g. breaking news story), that it can load a few documents, the HTML, maybe some images, yet nothing is displayed. After a few minutes of staring at a blank page with "Loading 5 of 31 items (2 errors)" in the status bar it starts getting really tedious.

I suggest that, depending on the user's connection, a timeout period is set whereafter safari just displays whatever it's got, regardless of CSS.

• 56k dialup: timout of 10 seconds
• 2Mbit or under: 5s
• above 2Mbit: 2s

The user's connection speed is available/set via QuickTime.
Comment 1 Nicholas Shanks 2007-02-08 18:07:24 PST
I haven't seen this for about four months, can't reproduce it and never found out why it happened. Closing as WorksForMe. :-)