Bug 103399 - [EFL] Layout Test fast/forms/basic-buttons.html is flaky
Summary: [EFL] Layout Test fast/forms/basic-buttons.html is flaky
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-27 04:46 PST by Jussi Kukkonen (jku)
Modified: 2017-03-11 10:32 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jussi Kukkonen (jku) 2012-11-27 04:46:56 PST
The following layout test is flaky on EFL WK2 Debug
  fast/forms/basic-buttons.html
This can be reproduced easily with --iterations=2 : the second one will always fail.

--- fast/forms/basic-buttons-expected.txt
+++ fast/forms/basic-buttons-actual.txt
@@ -42,7 +42,7 @@
                   RenderImage {IMG} at (0,5) size 10x10
             RenderTableCell {TD} at (229,33) size 157x20 [r=1 c=2 rs=1 cs=1]
               RenderText {#text} at (1,1) size 104x19
-                text run at (1,1) width 104: "(40, 34) (36, 30)"
+                text run at (1,1) width 104: "(40, 44) (36, 40)"
             RenderTableCell {TD} at (386,20) size 132x46 [r=1 c=3 rs=1 cs=1]
               RenderButton {INPUT} at (3,3) size 56x40 [bgcolor=#C0C0C0] [border: (2px outset #C0C0C0)]
                 RenderBlock (anonymous) at (17,10) size 22x18
@@ -61,7 +61,7 @@
                   RenderImage {IMG} at (0,5) size 10x10
             RenderTableCell {TD} at (229,79) size 157x20 [r=2 c=2 rs=1 cs=1]
               RenderText {#text} at (1,1) size 104x19
-                text run at (1,1) width 104: "(40, 34) (36, 30)"
+                text run at (1,1) width 104: "(40, 44) (36, 40)"
             RenderTableCell {TD} at (386,66) size 132x46 [r=2 c=3 rs=1 cs=1]
               RenderButton {INPUT} at (3,3) size 56x40 [bgcolor=#C0C0C0] [border: (2px outset #C0C0C0)]
                 RenderBlock (anonymous) at (17,10) size 22x18
@@ -80,7 +80,7 @@
                   RenderImage {IMG} at (0,5) size 10x10
             RenderTableCell {TD} at (229,125) size 157x20 [r=3 c=2 rs=1 cs=1]
               RenderText {#text} at (1,1) size 104x19
-                text run at (1,1) width 104: "(40, 34) (36, 30)"
+                text run at (1,1) width 104: "(40, 44) (36, 40)"
             RenderTableCell {TD} at (386,112) size 132x46 [r=3 c=3 rs=1 cs=1]
               RenderButton {INPUT} at (3,3) size 56x40 [bgcolor=#C0C0C0] [border: (2px outset #C0C0C0)]
                 RenderBlock (anonymous) at (17,10) size 22x18
@@ -99,7 +99,7 @@
                   RenderImage {IMG} at (0,5) size 10x10
             RenderTableCell {TD} at (229,171) size 157x20 [r=4 c=2 rs=1 cs=1]
               RenderText {#text} at (1,1) size 104x19
-                text run at (1,1) width 104: "(40, 34) (36, 30)"
+                text run at (1,1) width 104: "(40, 44) (36, 40)"
             RenderTableCell {TD} at (386,158) size 132x46 [r=4 c=3 rs=1 cs=1]
               RenderButton {INPUT} at (3,3) size 56x40 [bgcolor=#C0C0C0] [border: (2px outset #C0C0C0)]
                 RenderBlock (anonymous) at (17,10) size 22x18
@@ -118,7 +118,7 @@
                   RenderImage {IMG} at (0,5) size 10x10
             RenderTableCell {TD} at (229,217) size 157x20 [r=5 c=2 rs=1 cs=1]
               RenderText {#text} at (1,1) size 104x19
-                text run at (1,1) width 104: "(40, 34) (36, 30)"
+                text run at (1,1) width 104: "(40, 44) (36, 40)"
             RenderTableCell {TD} at (386,204) size 132x46 [r=5 c=3 rs=1 cs=1]
               RenderButton {INPUT} at (3,3) size 56x40 [bgcolor=#C0C0C0] [border: (2px outset #C0C0C0)]
                 RenderBlock (anonymous) at (17,10) size 22x18
@@ -137,7 +137,7 @@
                   RenderImage {IMG} at (0,5) size 10x10
             RenderTableCell {TD} at (229,263) size 157x20 [r=6 c=2 rs=1 cs=1]
               RenderText {#text} at (1,1) size 104x19
-                text run at (1,1) width 104: "(40, 34) (36, 30)"
+                text run at (1,1) width 104: "(40, 44) (36, 40)"
             RenderTableCell {TD} at (386,250) size 132x46 [r=6 c=3 rs=1 cs=1]
               RenderButton {INPUT} at (3,3) size 56x40 [bgcolor=#C0C0C0] [border: (2px outset #C0C0C0)]
                 RenderBlock (anonymous) at (17,10) size 22x18
@@ -156,7 +156,7 @@
                   RenderImage {IMG} at (0,5) size 10x10
             RenderTableCell {TD} at (229,309) size 157x20 [r=7 c=2 rs=1 cs=1]
               RenderText {#text} at (1,1) size 104x19
-                text run at (1,1) width 104: "(40, 34) (36, 30)"
+                text run at (1,1) width 104: "(40, 44) (36, 40)"
             RenderTableCell {TD} at (386,296) size 132x46 [r=7 c=3 rs=1 cs=1]
               RenderButton {INPUT} at (3,3) size 56x40 [bgcolor=#C0C0C0] [border: (2px outset #C0C0C0)]
                 RenderBlock (anonymous) at (17,10) size 22x18
Comment 1 Michael Catanzaro 2017-03-11 10:32:14 PST
Closing this bug because the EFL port has been removed from trunk.

If you feel this bug applies to a different upstream WebKit port and was closed in error, please either update the title and reopen the bug, or leave a comment to request this.