Bug 101371 - REGRESSION(r133529): Caused 15% memory regression on Chromium page cyclers (Requested by jsbell|gardener on #webkit).
Summary: REGRESSION(r133529): Caused 15% memory regression on Chromium page cyclers (R...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Review Bot
URL:
Keywords:
Depends on:
Blocks: 89235
  Show dependency treegraph
 
Reported: 2012-11-06 10:47 PST by WebKit Review Bot
Modified: 2012-11-06 11:40 PST (History)
5 users (show)

See Also:


Attachments
ROLLOUT of r133529 (490.47 KB, patch)
2012-11-06 10:47 PST, WebKit Review Bot
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Review Bot 2012-11-06 10:47:15 PST
http://trac.webkit.org/changeset/133529 broke the build:
Caused 15% memory regression on Chromium page cyclers (Requested by jsbell|gardener on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2012-11-06 10:47:58 PST
Created attachment 172616 [details]
ROLLOUT of r133529

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 3 WebKit Review Bot 2012-11-06 11:10:53 PST
Comment on attachment 172616 [details]
ROLLOUT of r133529

Clearing flags on attachment: 172616

Committed r133644: <http://trac.webkit.org/changeset/133644>
Comment 4 WebKit Review Bot 2012-11-06 11:10:56 PST
All reviewed patches have been landed.  Closing bug.
Comment 5 Eric Seidel (no email) 2012-11-06 11:38:27 PST
Thank you Ojan, Joshua.
Comment 6 Joshua Bell 2012-11-06 11:40:53 PST
FYI, I forgot to revert an expectation change (that I added...) so r133630 needed to be reverted too (as part of 133647) - just watch out for that test being flaky if this whole thing is re-landed.