Bug 95685

Summary: Move AllowShadowContent flag to HitTestRequest
Product: WebKit Reporter: Allan Sandfeld Jensen <allan.jensen>
Component: Layout and RenderingAssignee: Allan Sandfeld Jensen <allan.jensen>
Status: RESOLVED FIXED    
Severity: Normal CC: eric, tonikitoo
Priority: P2    
Version: 420+   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 95204    
Attachments:
Description Flags
Patch tonikitoo: review+, tonikitoo: commit-queue-

Description Allan Sandfeld Jensen 2012-09-03 06:42:08 PDT
The HitTestResult class currently has a flag that control whether shadow-content should be allowed in the result, but since it is not really part of the result but a parameter to the hit-test itself it doesn't really belong in the HitTestResult class. All other flags controlling the hit-test are stored in HitTestRequest, and I propose moving it there. 

This is a part of the work to also include a flag that controls if child-frame content is allowed. See bug #95204
Comment 1 Allan Sandfeld Jensen 2012-09-03 06:54:29 PDT
Created attachment 161919 [details]
Patch
Comment 2 Antonio Gomes 2012-09-03 07:15:04 PDT
Comment on attachment 161919 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=161919&action=review

r=me

please fix the method name before landing, and maybe strip out the supposedly unrelated change?

> Source/WebCore/rendering/HitTestRequest.h:56
> +    bool allowShadowContent() const { return m_requestType & AllowShadowContent; }

I think it should be allowsShadowContent

> Source/WebCore/rendering/HitTestResult.cpp:107
> -    , m_region(region)
> +    , m_region(region ? region : other.m_region)

unrelated

> Source/WebCore/rendering/HitTestResult.h:58
> -    HitTestLocation(const HitTestLocation&, const LayoutSize& offset, RenderRegion*);
> +    HitTestLocation(const HitTestLocation&, const LayoutSize& offset, RenderRegion* = 0);

unrelated?
Comment 3 Allan Sandfeld Jensen 2012-09-03 07:27:04 PDT
(In reply to comment #2)
> (From update of attachment 161919 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=161919&action=review
> 
> r=me
> 
> please fix the method name before landing, and maybe strip out the supposedly unrelated change?
> 
I will. You are right that the two changes were incorrectly included in this patch.
Comment 4 Allan Sandfeld Jensen 2012-09-03 07:41:22 PDT
Committed r127421: <http://trac.webkit.org/changeset/127421>