Bug 94341

Summary: [EFL][Qt] New inspector/timeline/timeline-decode-resize.html fails with timeout
Product: WebKit Reporter: Sudarsana Nagineni (babu) <naginenis>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED INVALID    
Severity: Normal CC: caseq, ossy, pfeldman, rogulenko, zoltan
Priority: P2 Keywords: Qt, QtTriaged
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 79668, 87008, 90277    

Comment 1 Sudarsana Nagineni (babu) 2012-08-17 07:15:21 PDT
Skipping test for EFL in bug 94344.
Comment 2 Csaba Osztrogon√°c 2012-09-13 04:00:43 PDT
It is skipped on Qt too, please unskip it with the proper fix.
Comment 3 Zoltan Horvath 2012-09-21 00:31:01 PDT
This test times out because of missing libwebp library.

After installing it, the timeout becomes a failure:


--- /home/zoltan/prog/local/WebKit/WebKitBuild/Release/layout-test-results/inspector/timeline/timeline-decode-resize-expected.txt
+++ /home/zoltan/prog/local/WebKit/WebKitBuild/Release/layout-test-results/inspector/timeline/timeline-decode-resize-actual.txt
@@ -14,19 +14,6 @@
     type : "DecodeImage"
     usedHeapSize : <number>
 }
-ResizeImage Properties:
-{
-    children : <object>
-    counters : <object>
-    data : {
-        cached : true
-    }
-    endTime : <number>
-    stackTrace : <object>
-    startTime : <number>
-    type : "ResizeImage"
-    usedHeapSize : <number>
-}
 DecodeImage Properties:
 {
     children : <object>
@@ -38,19 +25,6 @@
     stackTrace : <object>
     startTime : <number>
     type : "DecodeImage"
-    usedHeapSize : <number>
-}
-ResizeImage Properties:
-{
-    children : <object>
-    counters : <object>
-    data : {
-        cached : true
-    }
-    endTime : <number>
-    stackTrace : <object>
-    startTime : <number>
-    type : "ResizeImage"
     usedHeapSize : <number>
 }
 DecodeImage Properties:
@@ -66,19 +40,6 @@
     type : "DecodeImage"
     usedHeapSize : <number>
 }
-ResizeImage Properties:
-{
-    children : <object>
-    counters : <object>
-    data : {
-        cached : true
-    }
-    endTime : <number>
-    stackTrace : <object>
-    startTime : <number>
-    type : "ResizeImage"
-    usedHeapSize : <number>
-}
 DecodeImage Properties:
 {
     children : <object>
@@ -90,19 +51,6 @@
     stackTrace : <object>
     startTime : <number>
     type : "DecodeImage"
-    usedHeapSize : <number>
-}
-ResizeImage Properties:
-{
-    children : <object>
-    counters : <object>
-    data : {
-        cached : true
-    }
-    endTime : <number>
-    stackTrace : <object>
-    startTime : <number>
-    type : "ResizeImage"
     usedHeapSize : <number>
 }
 DecodeImage Properties:
@@ -118,19 +66,6 @@
     type : "DecodeImage"
     usedHeapSize : <number>
 }
-ResizeImage Properties:
-{
-    children : <object>
-    counters : <object>
-    data : {
-        cached : true
-    }
-    endTime : <number>
-    stackTrace : <object>
-    startTime : <number>
-    type : "ResizeImage"
-    usedHeapSize : <number>
-}
 DecodeImage Properties:
 {
     children : <object>
@@ -142,19 +77,6 @@
     stackTrace : <object>
     startTime : <number>
     type : "DecodeImage"
-    usedHeapSize : <number>
-}
-ResizeImage Properties:
-{
-    children : <object>
-    counters : <object>
-    data : {
-        cached : true
-    }
-    endTime : <number>
-    stackTrace : <object>
-    startTime : <number>
-    type : "ResizeImage"
     usedHeapSize : <number>
 }
 DecodeImage Properties:
@@ -170,17 +92,4 @@
     type : "DecodeImage"
     usedHeapSize : <number>
 }
-ResizeImage Properties:
-{
-    children : <object>
-    counters : <object>
-    data : {
-        cached : false
-    }
-    endTime : <number>
-    stackTrace : <object>
-    startTime : <number>
-    type : "ResizeImage"
-    usedHeapSize : <number>
-}
Comment 4 Zoltan Horvath 2012-09-21 23:44:34 PDT
The problem is with this thing that the image resizing/scaling is happening at drawtime in Qt port, so we don't have a separate phase (to measure) for resizing the image. 

You can check it in: Source/WebCore/platform/graphics/qt/ImageQt.cpp void BitmapImage::draw(...)
Comment 5 Brian Burg 2014-12-17 17:48:48 PST
The related test(s) have been removed from trunk.