Bug 94080

Summary: Layout Test fast/overflow/line-clamp-and-columns.html is failing
Product: WebKit Reporter: Zan Dobersek <zan>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: cmuppala, inferno, mikhail.pozdnyakov, ojan, ossy
Priority: P2 Keywords: LayoutTestFailure
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
GTK diff image
none
GTK diff image none

Description Zan Dobersek 2012-08-15 01:20:11 PDT
The following layout test is failing on non-Chromium platforms since it was introduced in r125635
http://trac.webkit.org/changeset/125635

fast/overflow/line-clamp-and-columns.html
http://test-results.appspot.com/dashboards/flakiness_dashboard.html#group=%40ToT%20-%20webkit.org&tests=fast%2Foverflow%2Fline-clamp-and-columns.html
Comment 1 Zan Dobersek 2012-08-15 01:21:05 PDT
Created attachment 158523 [details]
GTK diff image

Attaching the diff image of the failure for the GTK port.
Comment 2 Zan Dobersek 2012-08-15 01:22:38 PDT
Created attachment 158524 [details]
GTK diff image

Reattaching a proper image.
Comment 3 Mikhail Pozdnyakov 2012-08-16 00:10:18 PDT
Have the same problem on EFL port.
Comment 4 Abhishek Arya 2012-08-16 00:15:43 PDT
Ojan, i think it will be ok to convert it into dumpAsText test since it was actually testing a crash. it seems to be causing problems on other platforms too like lion too - http://build.webkit.org/results/Apple%20Lion%20Release%20WK1%20(Tests)/r125742%20(2429)/results.html
Comment 5 Abhishek Arya 2012-08-16 14:05:18 PDT
*** Bug 94250 has been marked as a duplicate of this bug. ***
Comment 6 Abhishek Arya 2012-08-16 14:06:00 PDT
I think the -expected html had 51 px which might be causing the extra 1 px line. Ojan, did you get a chance to take a look.
Comment 7 Ojan Vafai 2012-08-16 14:28:21 PDT
Sorry for the break...I'll fix this soon.
Comment 8 Ojan Vafai 2012-08-16 15:16:53 PDT
http://trac.webkit.org/changeset/125813