Bug 93044

Summary: Make double tap gesture send dblclick event
Product: WebKit Reporter: Rick Byers <rbyers>
Component: UI EventsAssignee: Rick Byers <rbyers>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: rjkroege, sadrul
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 93045    

Description Rick Byers 2012-08-02 16:24:45 PDT
PlatformEvent::GestureTap triggers a mousedown/mouseup/click event sequence.
Similarily, a double tap gesture should be sending mousedown/mouseup/click events with detail=2 (click count) and a dblclick event.  Instead today it just behaves like two taps (eg. both with click count == 1).
Comment 1 Rick Byers 2012-08-02 16:28:41 PDT
Note that I can't implement this by consuming GestureDoubleTap.  We want to send GestureTap for the second tap (eg. a element that listens just to taps should be triggerable over and over again), but the derived mouse events it generates need to be different (have a click count of 2).

Therefore I will add a tap count to GestureTap, analogous to the clickCount in PlatformMouseEvent
Comment 2 Rick Byers 2012-08-03 07:23:30 PDT
Whoops, I did already have a bug for this.

*** This bug has been marked as a duplicate of bug 92412 ***