Bug 90049

Summary: [Qt] EWS bots should call qmake always
Product: WebKit Reporter: Csaba Osztrogonác <ossy>
Component: Tools / TestsAssignee: Csaba Osztrogonác <ossy>
Status: RESOLVED FIXED    
Severity: Normal CC: dbates, hausmann, ossy, vestbo, webkit.review.bot
Priority: P2 Keywords: Qt, QtTriaged
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
Patch none

Description Csaba Osztrogonác 2012-06-26 23:12:56 PDT
When the latest build suceeded and there isn't new SVN revision, 
buildHint in webkitdirs.pm isn't "incremental", but "". It is
correct behaviour for developer build, but it isn't for EWS.

Unfortunately it can cause and it causes incremental build problems on the 
EWS bots sometimes. Here is an example: https://bugs.webkit.org/show_bug.cgi?id=89939

I'm going to check how can we make the EWS bots do full incremental build always
(call qmake always to regenerate dependency) to avoid these false positive alarms.

Tor Arne, if you have any idea how to fix it, please share with me. :) Thanks in advance.
Comment 1 Tor Arne Vestbø 2012-06-27 01:53:19 PDT
One option would be to run build-webkit with --makeargs=incremental
Comment 2 Csaba Osztrogonác 2012-06-27 02:19:14 PDT
(In reply to comment #1)
> One option would be to run build-webkit with --makeargs=incremental

Thanks, it is the best option.
We don't have to modify anything in the build system.

I added the following env to our EWS config:
export BUILD_WEBKIT_ARGS=--makeargs=incremental

Now it works fine. ;-)
Comment 3 Csaba Osztrogonác 2012-12-20 05:05:06 PST
Reopen, because "export BUILD_WEBKIT_ARGS=--makeargs=incremental" wasn't
a good idea. Because now it causes many false negative red EWS bubbles.

The problem is when a patch changes any configuration which 
triggers "make wipeclean" before anything else. But in this 
case "make incremental wipeclean" is called, which is incorrect,
and makes the build fail because of race condition.

I think we should handle it in webkitdirs.pm and set $needsIncrementalBuild
if CONFIG+=buildbot is used instead of setting this buggy env on the EWS bots.

Patch is coming.
Comment 4 Csaba Osztrogonác 2012-12-20 05:06:26 PST
Created attachment 180324 [details]
Patch
Comment 5 Csaba Osztrogonác 2012-12-20 05:08:28 PST
Here is an example for false negative results - https://bugs.webkit.org/show_bug.cgi?id=104804
Comment 6 Csaba Osztrogonác 2012-12-20 05:46:54 PST
Comment on attachment 180324 [details]
Patch

Clearing flags on attachment: 180324

Committed r138246: <http://trac.webkit.org/changeset/138246>
Comment 7 Csaba Osztrogonác 2012-12-20 05:46:59 PST
All reviewed patches have been landed.  Closing bug.