Bug 89469

Summary: Turn off the global new/delete override
Product: WebKit Reporter: Martin Robinson <mrobinson>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: gustavo, wingo, xan.lopez
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   

Description Martin Robinson 2012-06-19 07:35:23 PDT
First reported here: https://plus.google.com/104877287288155269055/posts/grHDgRNc1gi

My hypothesis is that we've always had global new/delete overriding turned on without realizing it.  When I turned off symbol hiding by default to avoiding compiling JSC multiple times into libraries and applications this badness was exposed to the world.
Comment 1 Martin Robinson 2012-06-19 08:21:51 PDT

*** This bug has been marked as a duplicate of bug 89358 ***