Bug 88857

Summary: [Qt][Wk1] new fast/dom/shadow/elements-in-frameless-document.html fails
Product: WebKit Reporter: János Badics <jbadics>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED INVALID    
Severity: Normal CC: dglazkov, morrita, ossy
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 87008, 88148    

Description János Badics 2012-06-12 04:31:31 PDT
A new test: fast/dom/shadow/elements-in-frameless-document.html fails on Qt-wk1 due to missing SHADOW_DOM feature since it was released in r120051.

-PASS window.HTMLContentElement is content.constructor
-PASS window.HTMLShadowElement is shadow.constructor
+FAIL window.HTMLContentElement should be [object HTMLUnknownElementConstructor] (of type object). Was undefined (of type undefined).
+FAIL window.HTMLShadowElement should be [object HTMLUnknownElementConstructor] (of type object). Was undefined (of type undefined).
 Moving to the main document.
-PASS window.HTMLContentElement is content.constructor
-PASS window.HTMLShadowElement is shadow.constructor
+FAIL window.HTMLContentElement should be [object HTMLUnknownElementConstructor] (of type object). Was undefined (of type undefined).
+FAIL window.HTMLShadowElement should be [object HTMLUnknownElementConstructor] (of type object). Was undefined (of type undefined).

The original bug can bee seen at
https://bugs.webkit.org/show_bug.cgi?id=88148
Comment 1 János Badics 2012-06-12 04:36:55 PDT

*** This bug has been marked as a duplicate of bug 88852 ***
Comment 2 Csaba Osztrogonác 2012-06-12 04:41:28 PDT
We don't need this bug. We should add this test to qt/Skipped list's "# ENABLE(SHADOW_DOM) is disabled." section ... (But it seems it will be rolled out, so now we shouldn't do anything.)