Bug 87987

Summary: Support throwing TypeError from WebIDL bindings
Product: WebKit Reporter: Alec Flett <alecflett>
Component: WebCore JavaScriptAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: jsbell
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 85513    

Description Alec Flett 2012-05-31 10:26:09 PDT
The current WebIDL scripts / bindings dont' support any means to throw a JavaScript TypeError. We'll probably need to (taking a cue from Mozilla) have a special error code.
Comment 1 Joshua Bell 2012-07-18 16:06:18 PDT
Whoops, didn't notice we had an existing bug for this. Patch and tests in the other one, so marking this as the dupe.

*** This bug has been marked as a duplicate of bug 91679 ***