Bug 87956

Summary: New fast/dom/Window/mozilla-focus-blur.html introduced in r118916 fails
Product: WebKit Reporter: Csaba Osztrogonác <ossy>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: abarth, jochen, kadam, ossy
Priority: P2 Keywords: Qt, QtTriaged
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 86969, 87008    

Description Csaba Osztrogonác 2012-05-31 05:01:14 PDT
This test introduced in r118916 and fails on Qt with the following message:

--- /ramdisk/qt-linux-64-release/build/layout-test-results/fast/dom/Window/mozilla-focus-blur-expected.txt 
+++ /ramdisk/qt-linux-64-release/build/layout-test-results/fast/dom/Window/mozilla-focus-blur-actual.txt 
@@ -6,6 +6,6 @@
 PASS: The focus should not have been changed!
 PASS: The focus should not have been changed with URL=data:text/html,<script>opener.focus();opener.postMessage("", "*");</script>
 PASS: The focus should not have been changed with URL=data:text/html,<script>blur();opener.postMessage("", "*");</script>
-PASS: The last opened window should be able to get focus
+FAIL: The last opened window should be able to get focus
 PASS: All tests finished
Comment 1 Csaba Osztrogonác 2012-05-31 05:07:23 PDT
Skipped by http://trac.webkit.org/changeset/119091,
please unskip it with the proper fix.
Comment 2 jochen 2012-05-31 13:38:53 PDT
fyi, the test result doesn't match the test in the bug's title
Comment 3 Csaba Osztrogonác 2012-07-11 09:28:03 PDT
(In reply to comment #2)
> fyi, the test result doesn't match the test in the bug's title

Yay, I made something wrong. Thanks for the notification.

*** This bug has been marked as a duplicate of bug 87951 ***
Comment 4 Ádám Kallai 2012-10-11 09:30:53 PDT
Now this test is working on Qt Wk2. But it still fails on Qt Wk1. I added to Qt Wk1 TestExpectations.
Committed r131051: <http://trac.webkit.org/changeset/131051>