Bug 86929

Summary: REGRESSION(117646): fast/canvas/webgl/glsl-conformance.html is crashing in the DFG
Product: WebKit Reporter: Filip Pizlo <fpizlo@apple.com>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned@lists.webkit.org>
Status: RESOLVED FIXED    
Severity: Normal CC: barraclough@apple.com, beidson@apple.com, fpizlo@apple.com, ggaren@apple.com, oliver@apple.com
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
the patch oliver: review+

Description From 2012-05-18 17:27:17 PST
This appears to be due to a branch simplification assuming that a particular block is unreachable, even though it is.
------- Comment #1 From 2012-05-18 17:39:30 PST -------
Created an attachment (id=142831) [details]
the patch
------- Comment #2 From 2012-05-18 17:54:35 PST -------
Landed in http://trac.webkit.org/changeset/117661