Bug 84814

Summary: Rename CSSStyleSelector files to StyleResolver.
Product: WebKit Reporter: Alexis Menard (darktears) <menard>
Component: CSSAssignee: Alexis Menard (darktears) <menard>
Status: RESOLVED FIXED    
Severity: Normal CC: eric.carlson, feature-media-reviews, japhet, kling, koivisto, macpherson, rakuco, tkent, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 42764    
Attachments:
Description Flags
Patch
none
Patch
none
Patch
none
Patch none

Description Alexis Menard (darktears) 2012-04-24 18:07:06 PDT
Rename CSSStyleSelector files to StyleResolver.
Comment 1 Alexis Menard (darktears) 2012-04-24 18:20:35 PDT
Created attachment 138710 [details]
Patch
Comment 2 WebKit Review Bot 2012-04-24 18:24:04 PDT
Attachment 138710 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/CMakeLists.txt', u'Source/W..." exit_code: 1
Source/WebCore/css/StyleResolver.h:94:  More than one command on the same line  [whitespace/newline] [4]
Source/WebCore/css/StyleResolver.h:122:  More than one command on the same line  [whitespace/newline] [4]
Source/WebCore/css/StyleResolver.cpp:1506:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:1577:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:1639:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:1759:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:1806:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:2164:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:2169:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:4241:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:4257:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:4265:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:4275:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:5340:  static_cast is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/css/StyleResolver.cpp:5341:  static_cast is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/css/StyleResolver.cpp:5457:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:5534:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:5753:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Total errors found: 18 in 73 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Alexis Menard (darktears) 2012-04-24 18:25:17 PDT
(In reply to comment #2)
> Attachment 138710 [details] did not pass style-queue:
> 
> Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/CMakeLists.txt', u'Source/W..." exit_code: 1
> Source/WebCore/css/StyleResolver.h:94:  More than one command on the same line  [whitespace/newline] [4]
> Source/WebCore/css/StyleResolver.h:122:  More than one command on the same line  [whitespace/newline] [4]
> Source/WebCore/css/StyleResolver.cpp:1506:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
> Source/WebCore/css/StyleResolver.cpp:1577:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
> Source/WebCore/css/StyleResolver.cpp:1639:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
> Source/WebCore/css/StyleResolver.cpp:1759:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
> Source/WebCore/css/StyleResolver.cpp:1806:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
> Source/WebCore/css/StyleResolver.cpp:2164:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
> Source/WebCore/css/StyleResolver.cpp:2169:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
> Source/WebCore/css/StyleResolver.cpp:4241:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
> Source/WebCore/css/StyleResolver.cpp:4257:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
> Source/WebCore/css/StyleResolver.cpp:4265:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
> Source/WebCore/css/StyleResolver.cpp:4275:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
> Source/WebCore/css/StyleResolver.cpp:5340:  static_cast is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
> Source/WebCore/css/StyleResolver.cpp:5341:  static_cast is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
> Source/WebCore/css/StyleResolver.cpp:5457:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
> Source/WebCore/css/StyleResolver.cpp:5534:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
> Source/WebCore/css/StyleResolver.cpp:5753:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
> Total errors found: 18 in 73 files
> 
> 
> If any of these errors are false positives, please file a bug against check-webkit-style.

We can ignore that I believe. I reported a bug already for "Local variables should never be PassRefPtr...".
Comment 4 Build Bot 2012-04-24 19:09:34 PDT
Comment on attachment 138710 [details]
Patch

Attachment 138710 [details] did not pass win-ews (win):
Output: http://queues.webkit.org/results/12522376
Comment 5 Alexis Menard (darktears) 2012-04-24 19:25:07 PDT
Created attachment 138719 [details]
Patch
Comment 6 WebKit Review Bot 2012-04-24 19:29:15 PDT
Attachment 138719 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/CMakeLists.txt', u'Source/W..." exit_code: 1
Source/WebCore/css/StyleResolver.h:94:  More than one command on the same line  [whitespace/newline] [4]
Source/WebCore/css/StyleResolver.h:122:  More than one command on the same line  [whitespace/newline] [4]
Source/WebCore/css/StyleResolver.cpp:1506:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:1577:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:1639:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:1759:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:1806:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:2164:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:2169:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:4241:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:4257:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:4265:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:4275:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:5340:  static_cast is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/css/StyleResolver.cpp:5341:  static_cast is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/css/StyleResolver.cpp:5457:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:5534:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:5753:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Total errors found: 18 in 73 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 7 Darin Adler 2012-04-24 19:58:53 PDT
Comment on attachment 138719 [details]
Patch

I don’t know enough about how gitsvn works to know if this will preserve the file history or not. At first glance, it looks like it will not. If it was preserving file history correctly, then I would have said review+.
Comment 8 Alexis Menard (darktears) 2012-04-25 05:13:32 PDT
Created attachment 138786 [details]
Patch
Comment 9 Alexis Menard (darktears) 2012-04-25 05:14:36 PDT
(In reply to comment #7)
> (From update of attachment 138719 [details])
> I don’t know enough about how gitsvn works to know if this will preserve the file history or not. At first glance, it looks like it will not. If it was preserving file history correctly, then I would have said review+.

I re-uploaded the diff with svn and made sure I did svn mv. But I think at the end it was the same.
Comment 10 WebKit Review Bot 2012-04-25 05:16:42 PDT
Attachment 138786 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/CMakeLists.txt', u'Source/W..." exit_code: 1
Source/WebCore/css/StyleResolver.h:94:  More than one command on the same line  [whitespace/newline] [4]
Source/WebCore/css/StyleResolver.h:122:  More than one command on the same line  [whitespace/newline] [4]
Source/WebCore/css/StyleResolver.cpp:1506:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:1577:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:1639:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:1759:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:1806:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:2164:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:2169:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:4241:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:4257:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:4265:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:4275:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:5340:  static_cast is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/css/StyleResolver.cpp:5341:  static_cast is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/css/StyleResolver.cpp:5457:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:5534:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:5753:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Total errors found: 18 in 73 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 11 Gyuyoung Kim 2012-04-25 05:56:13 PDT
Comment on attachment 138786 [details]
Patch

Attachment 138786 [details] did not pass efl-ews (efl):
Output: http://queues.webkit.org/results/12523588
Comment 12 Alexis Menard (darktears) 2012-04-25 07:10:54 PDT
Created attachment 138804 [details]
Patch
Comment 13 WebKit Review Bot 2012-04-25 07:15:01 PDT
Attachment 138804 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/CMakeLists.txt', u'Source/W..." exit_code: 1
Source/WebCore/css/StyleResolver.h:94:  More than one command on the same line  [whitespace/newline] [4]
Source/WebCore/css/StyleResolver.h:122:  More than one command on the same line  [whitespace/newline] [4]
Source/WebCore/css/StyleResolver.cpp:1506:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:1577:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:1639:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:1759:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:1806:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:2164:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:2169:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:4241:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:4257:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:4265:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:4275:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:5340:  static_cast is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/css/StyleResolver.cpp:5341:  static_cast is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/css/StyleResolver.cpp:5457:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:5534:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Source/WebCore/css/StyleResolver.cpp:5753:  Local variables should never be PassRefPtr (see http://webkit.org/coding/RefPtr.html).  [readability/pass_ptr] [5]
Total errors found: 18 in 73 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 14 WebKit Review Bot 2012-04-25 08:48:32 PDT
Comment on attachment 138804 [details]
Patch

Clearing flags on attachment: 138804

Committed r115215: <http://trac.webkit.org/changeset/115215>
Comment 15 WebKit Review Bot 2012-04-25 08:48:43 PDT
All reviewed patches have been landed.  Closing bug.
Comment 16 Alexis Menard (darktears) 2012-04-25 09:51:45 PDT
(In reply to comment #15)
> All reviewed patches have been landed.  Closing bug.

Build fix on Windows : http://trac.webkit.org/changeset/115221