Bug 84282

Summary: Editing large canvas elements causes transformed text elsewhere on the page to render poorly
Product: WebKit Reporter: Jason Merrill <jason>
Component: CanvasAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: simon.fraser
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   

Description Jason Merrill 2012-04-18 14:32:45 PDT
If there is a canvas element on the page with width and height larger than 71, text anywhere on the page will lose rasterization fidelity when the canvas API is used. This problem exists in the current public version of Chrome as well, but the magic number there is 256x256.

Here are jsfiddles demonstrating the problem:

canvas size below threshold, scaled text looks good: http://jsfiddle.net/AQk5z/2/

canvas size above threshold, scaled text looks bad after using canvas API: http://jsfiddle.net/BxrXk/1/
Comment 1 Jason Merrill 2012-04-19 10:34:05 PDT
Sorry, pasted the wrong fiddles:

> canvas size below threshold, scaled text looks good: http://jsfiddle.net/AQk5z/2/
below threshold: http://jsfiddle.net/AQk5z/3/ 
> canvas size above threshold, scaled text looks bad after using canvas API: http://jsfiddle.net/BxrXk/1/
above threshold: http://jsfiddle.net/BxrXk/2/
Comment 2 Simon Fraser (smfr) 2012-04-19 11:32:15 PDT

*** This bug has been marked as a duplicate of bug 23364 ***