Bug 83867

Summary: getComputedStyle on detached caption element for caption-side always returns an empty string
Product: WebKit Reporter: Allan Jardine <allan.jardine>
Component: TablesAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: ojan
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   

Description Allan Jardine 2012-04-13 01:07:38 PDT
I've just been looking at reading the CSS 'caption-side' property for a caption in my tables, but I was getting an empty string. On a bit of experimentation I discovered that this is occurring because I had removed the element from the document (to clarify if the node is left in the document it works as expected).

I've put together a jsfiddle example here: http://jsfiddle.net/UqY8X/ .

I must confess I can't imagine that this will be a particularly high priority issue! Or indeed it might even be won't fix, but I thought I'd report it anyway, as it wasn't what I was expecting to happen.
Comment 1 Ojan Vafai 2012-10-12 13:11:43 PDT

*** This bug has been marked as a duplicate of bug 14563 ***