Bug 83310

Summary: [Chromium] Correct misleading trace event names in Canvas2DLayerChromium
Product: WebKit Reporter: Justin Novosad <junov>
Component: CanvasAssignee: Justin Novosad <junov>
Severity: Normal CC: cc-bugs, jamesr, senorblanco, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Description Flags
Patch none

Description Justin Novosad 2012-04-05 13:46:05 PDT
The trace event "SkDeferredCanvas::flush" in paintContentsIfDirty() is poorly named because the code gets called even when the canvas is a regular SkCanvas, in which case it wraps a call to GrContext::flush if the canvas is accelerated.  A couple lines lower, the trace event named "GrContext::flush" is also poorly named because it assumes that GrContext::flush is the main task performed by GraphicsContext3D::flush, which is not the case since the GrContext may have already been flushed by the call to SkCanvas::flush.  Better just call it "GraphicsContext3D::flush"
Comment 1 Justin Novosad 2012-04-05 13:48:35 PDT
Created attachment 135894 [details]
Comment 2 Adrienne Walker 2012-04-05 14:16:46 PDT
Comment on attachment 135894 [details]

Yay, for less confusion.
Comment 3 WebKit Review Bot 2012-04-05 15:02:15 PDT
Comment on attachment 135894 [details]

Clearing flags on attachment: 135894

Committed r113384: <http://trac.webkit.org/changeset/113384>
Comment 4 WebKit Review Bot 2012-04-05 15:02:36 PDT
All reviewed patches have been landed.  Closing bug.