Bug 83052

Summary: -webkit-text-size-adjust prevents users from explicitly overriding font size
Product: WebKit Reporter: James Craig <jcraig>
Component: CSSAssignee: Nobody <webkit-unassigned>
Status: CLOSED DUPLICATE    
Severity: Normal CC: ap, eoconnor, jcraig, mitz, simon.fraser
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: Macintosh   
OS: OS X 10.7   

Description James Craig 2012-04-03 11:26:56 PDT
rdar://problem/11175828

* SUMMARY
Accessibility: -webkit-text-size-adjust prevents zoom users from overriding font size

* STEPS TO REPRODUCE
1. Load attached test case that uses -webkit-text-size-adjust: none;
2. Cmd= and Cmd- to increase and decrease the font size.

* RESULTS
Does not work. This is a serious accessibility bug for low-vision or zoom users, and a usability bug for all users.

* REGRESSION
Regression occurred at the time text-size-adjust was implemented.

* NOTES
This property should prevent webkit from resizing text automatically, but it should never prevent the user from resizing the text explicitly.


This is also in violation of WCAG Guideline 1.4.4 and UAAG Guideline 4.1.

WCAG Guideline 1.4:
http://www.w3.org/TR/WCAG/#visual-audio-contrast
1.4.4 Resize text: Except for captions and images of text, text can be resized without assistive technology up to 200 percent without loss of content or functionality. (Level AA)

UAAG Guideline 4. Ensure user control of rendering
http://www.w3.org/TR/UAAG/guidelines.html#gl-user-control-styles
4.1 Configure text scale (P1) (1) Allow global configuration of the scale of visually rendered text content. Preserve distinctions in the size of rendered text as the user increases or decreases the scale. (2) As part of satisfying provision one of this checkpoint, provide a configuration option to override rendered text sizes specified by the author or user agent defaults.
Comment 1 Alexey Proskuryakov 2012-04-04 13:17:46 PDT
See also: bug 56543.
Comment 2 Simon Fraser (smfr) 2012-04-04 13:21:57 PDT

*** This bug has been marked as a duplicate of bug 56543 ***