Bug 82020

Summary: plugins/netscape-dom-access-and-reload.html fails on all platforms
Product: WebKit Reporter: mitz
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED WONTFIX    
Severity: Normal CC: ap, dmichael, eric, mrobinson, ossy, p.jacquemart, pnormand, rniwa, simon.fraser, webkit-bug-importer
Priority: P2 Keywords: InRadar, LayoutTestFailure
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 80428    

Description mitz 2012-03-22 23:20:51 PDT
plugins/netscape-dom-access-and-reload.html was added in <http://trac.webkit.org/r111754> (the fix for bug 80428) and has been failing in Mac WebKit2 ever since.
Comment 1 Radar WebKit Bug Importer 2012-03-22 23:21:35 PDT
<rdar://problem/11106612>
Comment 2 mitz 2012-03-22 23:24:11 PDT
Added the current failing results as the expected results for Mac WebKit2 in <http://trac.webkit.org/r111831>.
Comment 3 Ryosuke Niwa 2012-03-23 02:11:06 PDT
The patch was rolled out in http://trac.webkit.org/changeset/111839.
I also removed the failing expectation you added in http://trac.webkit.org/changeset/111840.
Comment 4 mitz 2012-03-23 17:19:15 PDT
The test was re-added in <http://trac.webkit.org/r111890>, and it is failing again.
Comment 5 mitz 2012-03-23 17:23:06 PDT
Added the current failing results as the expected results for Mac WebKit2 in <http://trac.webkit.org/r111934>.
Comment 6 Philippe Normand 2012-03-26 00:31:45 PDT
(In reply to comment #5)
> Added the current failing results as the expected results for Mac WebKit2 in <http://trac.webkit.org/r111934>.

It also fails on Qt and GTK. I'm going to skip it for now on those ports.
Comment 7 Csaba Osztrogon√°c 2012-03-26 01:15:06 PDT
It should block the original bug, because now there isn't any relation added.
Comment 8 Alexey Proskuryakov 2013-10-24 10:08:01 PDT
*** Bug 82752 has been marked as a duplicate of this bug. ***
Comment 9 Pascal Jacquemart 2013-11-04 10:06:45 PST
Re-tested on GTK

I can confirm it fails while the running all the tests
But surprisingly this same test succeeds while running alone 

Within the whole suite the value read from "internals.numberOfLiveDocuments()" is set to 4 (whereas the expected value is 1)

The garbage collector is called several times:
- while loading the document
- after reload
- after a JavaScript call to "window.GCController.collect();"
But it seems to have no effect

Any idea? I have to investigate deeper...
Comment 10 Martin Robinson 2022-06-28 03:57:33 PDT
Support for plugins was removed in https://trac.webkit.org/changeset/265753/webkit.