Bug 81705

Summary: REGRESSION (r111416): fast/dom/prototype-inheritance-2.html is failing
Product: WebKit Reporter: mitz
Component: DOMAssignee: Vineet Chaudhary (vineetc) <code.vineet>
Status: RESOLVED FIXED    
Severity: Normal CC: code.vineet, haraken, ossy, pnormand, webkit.review.bot
Priority: P1 Keywords: LayoutTestFailure, Regression
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 80696    
Attachments:
Description Flags
Patch none

Description mitz 2012-03-20 15:30:39 PDT
<http://trac.webkit.org/r111416> caused fast/dom/prototype-inheritance-2.html to fail in Mac WebKit2, and, according to bug 80696 comment 59, also GTK and Qt.
Comment 1 mitz 2012-03-20 16:23:00 PDT
This is not port-specific at all.
Comment 2 mitz 2012-03-20 16:38:08 PDT
Updated the Mac expected results for this test in <http://trac.webkit.org/r111466>.
Comment 3 Philippe Normand 2012-03-21 02:07:19 PDT
I'll skip it in GTK.
Comment 4 Vineet Chaudhary (vineetc) 2012-03-21 03:19:08 PDT
I have figured out the reason for failing test.
I no sure why bot didn't catch this.
Comment 5 Vineet Chaudhary (vineetc) 2012-03-21 03:20:08 PDT
Created attachment 133002 [details]
Patch

Attaching patch to fix issue.
Sorry for the inconvenience caused.
Comment 6 Csaba Osztrogon√°c 2012-03-21 03:22:41 PDT
Comment on attachment 133002 [details]
Patch

rs=me
Comment 7 WebKit Review Bot 2012-03-21 04:21:41 PDT
Comment on attachment 133002 [details]
Patch

Clearing flags on attachment: 133002

Committed r111520: <http://trac.webkit.org/changeset/111520>
Comment 8 WebKit Review Bot 2012-03-21 04:21:46 PDT
All reviewed patches have been landed.  Closing bug.