Bug 81460

Summary: REGRESSION(r110072): Improper repainting on table with overflow: hidden
Product: WebKit Reporter: Julien Chaffraix <jchaffraix>
Component: Layout and RenderingAssignee: Julien Chaffraix <jchaffraix>
Status: RESOLVED FIXED    
Severity: Normal CC: dglazkov, jamesr, simon.fraser, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
URL: http://docs.fuelphp.com/
Attachments:
Description Flags
Proposed fix: call updateCachedSizeForOverflowClip.
none
Patch for landing none

Description Julien Chaffraix 2012-03-17 17:35:30 PDT
How to reproduce:

1. go to http://docs.fuelphp.com/
2. click on "TABLE OF CONTENTS"
3. hover over the links

(copied from downstream bug: http://crbug.com/117356)

The issue is that we are not repainting the link as we should (the CSS is updated if you query it). This is due to us not updating our cached repaint rectangle.

Patch forthcoming.
Comment 1 Julien Chaffraix 2012-03-17 17:55:45 PDT
Created attachment 132474 [details]
Proposed fix: call updateCachedSizeForOverflowClip.
Comment 2 Simon Fraser (smfr) 2012-03-18 10:52:39 PDT
Did this regress at some point?
Comment 3 Julien Chaffraix 2012-03-18 10:57:36 PDT
(In reply to comment #2)
> Did this regress at some point?

Yes, this is a regression from bug 75568 (as we don't have a layer in this case, we need to make sure we properly cache our updated size which we did not do in this case).
Comment 4 WebKit Review Bot 2012-03-18 11:54:02 PDT
Comment on attachment 132474 [details]
Proposed fix: call updateCachedSizeForOverflowClip.

Attachment 132474 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/11974982

New failing tests:
fast/repaint/table-hover-on-link.html
Comment 5 Julien Chaffraix 2012-03-19 18:19:30 PDT
Created attachment 132738 [details]
Patch for landing
Comment 6 Julien Chaffraix 2012-03-19 18:21:14 PDT
I tweaked the test a bit to avoid having platform-specific text dumps. Tested on Chromium-linux + SnowLeopard (both Chromium & Mac)
Comment 7 WebKit Review Bot 2012-03-19 22:38:02 PDT
Comment on attachment 132738 [details]
Patch for landing

Clearing flags on attachment: 132738

Committed r111360: <http://trac.webkit.org/changeset/111360>
Comment 8 WebKit Review Bot 2012-03-19 22:38:06 PDT
All reviewed patches have been landed.  Closing bug.