Bug 80378

Summary: REGRESSION(r109733): It broke Qt5 build system (Requested by Ossy on #webkit).
Product: WebKit Reporter: WebKit Review Bot <webkit.review.bot>
Component: New BugsAssignee: WebKit Review Bot <webkit.review.bot>
Status: RESOLVED INVALID    
Severity: Normal CC: ossy, vestbo
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
ROLLOUT of r109733 none

Description WebKit Review Bot 2012-03-05 22:18:57 PST
http://trac.webkit.org/changeset/109733 broke the build:
It broke Qt5 build system (Requested by Ossy on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2012-03-05 22:19:30 PST
Created attachment 130290 [details]
ROLLOUT of r109733

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Csaba Osztrogon√°c 2012-03-05 22:34:06 PST
Comment on attachment 130290 [details]
ROLLOUT of r109733

Rollout landed in http://trac.webkit.org/changeset/109862
Comment 3 Csaba Osztrogon√°c 2012-03-05 22:37:26 PST
Check this build: http://build.webkit.sed.hu/builders/x86-32%20Linux%20Qt%20Release%20-%20Qt5-WebKit1/builds/4360

run-javascriptcore-tests removed everything (DRT, libQtWebKit, ...):
Running: build-jsc --qt --release --32-bit --qt
Feature HAVE_FONTCONFIG added, clean build needed!

There is a serious problem with the original patch, it needs more investigation.