Bug 79390

Summary: REGRESSION (r108509-r108593 ): Crash clicking back button in WebKit::WebProcessProxy::didReceiveMessage
Product: WebKit Reporter: Kevin M. Dean <kevin>
Component: WebKit Misc.Assignee: Nobody <webkit-unassigned>
Status: RESOLVED INVALID    
Severity: Critical CC: ap, beidson, sharikov.suba
Priority: P1 Keywords: Regression
Version: 528+ (Nightly build)   
Hardware: Mac (Intel)   
OS: OS X 10.7   

Description Kevin M. Dean 2012-02-23 12:37:22 PST
Safari 5.2

Load a page and click to another page so that you can press the back button and then crash. When browser tries to re-open pages on restart it crashes again.

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   ???                           	0x00007fff64bc8020 0 + 140734883463200
1   com.apple.WebKit2             	0x0000000105638767 WebKit::WebProcessProxy::didReceiveMessage(CoreIPC::Connection*, CoreIPC::MessageID, CoreIPC::ArgumentDecoder*) + 149
2   com.apple.WebKit2             	0x00000001055bf02c WebKit::WebConnectionToWebProcess::didReceiveMessage(CoreIPC::Connection*, CoreIPC::MessageID, CoreIPC::ArgumentDecoder*) + 194
3   com.apple.WebKit2             	0x00000001055624f9 CoreIPC::Connection::dispatchMessage(CoreIPC::Connection::Message<CoreIPC::ArgumentDecoder>&) + 175
4   com.apple.WebKit2             	0x0000000105563a05 CoreIPC::Connection::dispatchMessages() + 147
5   com.apple.WebCore             	0x0000000106215e19 WebCore::RunLoop::performWork() + 89
6   com.apple.WebCore             	0x00000001062162d7 WebCore::RunLoop::performWork(void*) + 71
7   com.apple.CoreFoundation      	0x00007fff872d36e1 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
8   com.apple.CoreFoundation      	0x00007fff872d2f4d __CFRunLoopDoSources0 + 253
9   com.apple.CoreFoundation      	0x00007fff872f9d39 __CFRunLoopRun + 905
10  com.apple.CoreFoundation      	0x00007fff872f9676 CFRunLoopRunSpecific + 230
11  com.apple.HIToolbox           	0x00007fff922e331f RunCurrentEventLoopInMode + 277
12  com.apple.HIToolbox           	0x00007fff922ea51b ReceiveNextEventCommon + 181
13  com.apple.HIToolbox           	0x00007fff922ea456 BlockUntilNextEventMatchingListInMode + 62
14  com.apple.AppKit              	0x00007fff880ccf5d _DPSNextEvent + 659
15  com.apple.AppKit              	0x00007fff880cc861 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135
16  com.apple.Safari.framework    	0x00007fff8f692979 -[BrowserApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 162
17  com.apple.AppKit              	0x00007fff880c919d -[NSApplication run] + 470
18  com.apple.AppKit              	0x00007fff88347b88 NSApplicationMain + 867
19  com.apple.Safari.framework    	0x00007fff8f84ce12 SafariMain + 166
20  com.apple.Safari              	0x0000000104fcaf2c 0x104fca000 + 3884
Comment 1 Alexey Proskuryakov 2012-02-24 16:49:34 PST
Please file bugs about unreleased version of Safari via <http://bugreport.apple.com>.

Also, please note that nightly builds are only designed to work with the latest released version of Safari.
Comment 2 Kevin M. Dean 2012-02-24 17:06:28 PST
Hmm, but nightly was working until that build. Still seems important that something changed to introduce an issue to the next Safari from a nightly build update.
Comment 3 Brady Eidson 2012-02-24 17:12:23 PST
(In reply to comment #2)
> Hmm, but nightly was working until that build. Still seems important that something changed to introduce an issue to the next Safari from a nightly build update.

The WebKit project strives to remain backwards compatible with *released* software, not unreleased software.

You're using an unreleased version of Safari.
Comment 4 Alexey Proskuryakov 2012-02-26 13:12:11 PST
*** Bug 79557 has been marked as a duplicate of this bug. ***