Bug 79335

Summary: [Qt] Build fix. Qt WebKit2 can not be compiled due to QtWebPageEventHandler.
Product: WebKit Reporter: Dongseong Hwang <dongseong.hwang@intel.com>
Component: WebKit QtAssignee: Simon Hausmann <hausmann@webkit.org>
Status: RESOLVED FIXED    
Severity: Normal CC: abecsi@webkit.org, hausmann@webkit.org, jocelyn.turcotte@digia.com, kenneth@webkit.org, ossy@webkit.org
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
patch
hausmann: review-, hausmann: commit‑queue-
Patch
none
Patch none

Description From 2012-02-22 23:34:56 PST
I can not build WebKit2 on qt5 because QtWebPageEventHandler calls m_webView->setInputMethodHints(Qt::InputMethodHints(editor.inputMethodHints));.
------- Comment #1 From 2012-02-22 23:36:37 PST -------
Created an attachment (id=128407) [details]
patch
------- Comment #2 From 2012-02-23 00:16:01 PST -------
(From update of attachment 128407 [details])
Well, but this isn't quite correct either, we still _do_ need to propagate the input method hints to the input method. It's just that the mechanism has changed slightly. FWIW, the Qt 5 version that we're developing against currently still has this method (see webkit-qt mailing list of announcements of version changes).

That said, QQuickItem::setInputMethodHints has always been a convenience function for not having to re-implement the inputMethodQuery. Since we do that anyway though, we can apply a fix that works with any Qt 5 version, by responding to the Qt::ImHints input method query and returning the hints from the editor state there.
------- Comment #3 From 2012-02-23 00:44:01 PST -------
Ok.

I little know about Qt5, so I can not fix it.
I want someone to fix it.
------- Comment #4 From 2012-02-23 00:44:13 PST -------
(In reply to comment #0)
> I can not build WebKit2 on qt5 because QtWebPageEventHandler calls m_webView->setInputMethodHints(Qt::InputMethodHints(editor.inputMethodHints));.

QQuickItem does not have a setInputMethodHints(Qt::InputMethodHints hints) method.
------- Comment #5 From 2012-02-23 06:11:48 PST -------
*** Bug 79250 has been marked as a duplicate of this bug. ***
------- Comment #6 From 2012-02-23 06:16:13 PST -------
Created an attachment (id=128472) [details]
Patch
------- Comment #7 From 2012-02-23 06:18:03 PST -------
Created an attachment (id=128474) [details]
Patch

Patch that actually compiles :)
------- Comment #8 From 2012-02-23 10:35:22 PST -------
(From update of attachment 128474 [details])
Clearing flags on attachment: 128474

Committed r108639: <http://trac.webkit.org/changeset/108639>
------- Comment #9 From 2012-02-23 10:35:31 PST -------
All reviewed patches have been landed.  Closing bug.