Bug 79137

Summary: [chromium] Add compositor thread painting for scrollbar layers
Product: WebKit Reporter: Adrienne Walker <enne>
Component: WebCore Misc.Assignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: enne, jamesr, pkotwicz, trchen, vangelis
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 78028, 78872    
Bug Blocks:    
Attachments:
Description Flags
Patch none

Description Adrienne Walker 2012-02-21 11:57:08 PST
Once we have scrollbar layers (from bug 78872) and a way to encapsulate paint logic from scrollbars (bug 78028), we need to add a some logic to scrollbar layers that will let them execute this painting logic on the compositor thread.
Comment 1 Peter Kotwicz 2012-02-21 12:44:57 PST
Created attachment 128025 [details]
Patch
Comment 2 Peter Kotwicz 2012-02-21 12:54:15 PST
Please ignore patch

(In reply to comment #1)
> Created an attachment (id=128025) [details]
> Patch
Comment 3 Peter Kotwicz 2012-03-05 11:43:29 PST
Just doing some cleanup. This will be fixed with 78872?
Comment 4 Adrienne Walker 2012-03-05 11:46:43 PST
Yeah, this is a duplicate of 78872.

*** This bug has been marked as a duplicate of bug 78872 ***