Bug 78307

Summary: Dromaeo/dom-traverse.html should go fast
Product: WebKit Reporter: Adam Barth <abarth>
Component: New BugsAssignee: Adam Barth <abarth>
Status: RESOLVED FIXED    
Severity: Normal CC: arv, dglazkov, eric, haraken, japhet, rniwa, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch none

Description Adam Barth 2012-02-09 18:07:53 PST
Dromaeo/dom-traverse.html should go fast
Comment 1 Adam Barth 2012-02-09 18:33:39 PST
Created attachment 126424 [details]
Patch
Comment 2 Adam Barth 2012-02-09 18:40:17 PST
Created attachment 126427 [details]
Patch
Comment 3 Eric Seidel (no email) 2012-02-09 18:44:39 PST
Comment on attachment 126427 [details]
Patch

OK.
Comment 4 WebKit Review Bot 2012-02-09 23:10:07 PST
Comment on attachment 126427 [details]
Patch

Clearing flags on attachment: 126427

Committed r107367: <http://trac.webkit.org/changeset/107367>
Comment 5 WebKit Review Bot 2012-02-09 23:10:11 PST
All reviewed patches have been landed.  Closing bug.
Comment 7 Adam Barth 2012-02-10 13:01:57 PST
> It looks as if there were no impact on the graph.

I know!  That makes me sad.  I wonder if there's something wrong with the graph since I measured the improvement locally, both with total time and using a profiler.
Comment 8 Ryosuke Niwa 2012-02-10 13:03:56 PST
(In reply to comment #7)
> > It looks as if there were no impact on the graph.
> 
> I know!  That makes me sad.  I wonder if there's something wrong with the graph since I measured the improvement locally, both with total time and using a profiler.

Interesting. It's possible that there's some other bottle neck on slow machines (the bot is an old mac-mini)