Bug 78233

Summary: media/video-empty-source.html needs a rebaseline for chromium
Product: WebKit Reporter: Arun Patole <arun.patole>
Component: MediaAssignee: Ami Fischman <fischman>
Status: RESOLVED FIXED    
Severity: Normal CC: fischman, tony, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 47907    
Bug Blocks:    
Attachments:
Description Flags
Patch
none
Patch none

Description Arun Patole 2012-02-09 06:44:52 PST
After https://bugs.webkit.org/show_bug.cgi?id=47907 fix, media/video-empty-source.html fails. So currently added it to test_expectations.txt. Need to rebaseline it for chromium.
Comment 1 Ami Fischman 2012-02-09 13:34:28 PST
Created attachment 126361 [details]
Patch
Comment 2 WebKit Review Bot 2012-02-09 21:25:55 PST
Comment on attachment 126361 [details]
Patch

Rejecting attachment 126361 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '-..." exit_code: 2

Last 500 characters of output:
ing file LayoutTests/platform/chromium-win-xp/media/video-empty-source-expected.txt
patching file LayoutTests/platform/chromium-win/media/video-empty-source-expected.txt
patching file LayoutTests/platform/chromium/test_expectations.txt
Hunk #1 FAILED at 4012.
1 out of 1 hunk FAILED -- saving rejects to file LayoutTests/platform/chromium/test_expectations.txt.rej

Failed to run "[u'/mnt/git/webkit-commit-queue/Tools/Scripts/svn-apply', u'--force']" exit_code: 1 cwd: /mnt/git/webkit-commit-queue/

Full output: http://queues.webkit.org/results/11484524
Comment 3 Ami Fischman 2012-02-10 10:40:23 PST
Created attachment 126534 [details]
Patch
Comment 4 WebKit Review Bot 2012-02-10 15:31:02 PST
Comment on attachment 126534 [details]
Patch

Clearing flags on attachment: 126534

Committed r107448: <http://trac.webkit.org/changeset/107448>
Comment 5 WebKit Review Bot 2012-02-10 15:31:07 PST
All reviewed patches have been landed.  Closing bug.
Comment 6 Tony Chang 2012-02-10 16:46:57 PST
Ami, the test appears to be failing on Linux GPU.  Should I rebaseline?
Comment 7 Ami Fischman 2012-02-10 16:54:07 PST
(In reply to comment #6)
> Ami, the test appears to be failing on Linux GPU.  Should I rebaseline?

As long as the rebaseline looks similar to the non-gpu case (errored-out player), that's fine.
I'm curious why garden-o-matic didn't do the right thing; any ideas?
Comment 8 Tony Chang 2012-02-10 17:00:30 PST
(In reply to comment #7)
> (In reply to comment #6)
> > Ami, the test appears to be failing on Linux GPU.  Should I rebaseline?
> 
> As long as the rebaseline looks similar to the non-gpu case (errored-out player), that's fine.
> I'm curious why garden-o-matic didn't do the right thing; any ideas?

garden-o-matic doesn't know about the GPU bots.