Bug 78020

Summary: [Chromium] REGRESSION(r101854): Causing large amounts of unnecessary repainting.
Product: WebKit Reporter: David Reveman <reveman>
Component: WebCore Misc.Assignee: David Reveman <reveman>
Status: RESOLVED FIXED    
Severity: Normal CC: cc-bugs, jamesr, klobag, nduca, vangelis, wangxianzhu, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch none

Description David Reveman 2012-02-07 12:35:23 PST
http://trac.webkit.org/changeset/101854 is causing a performance regression by forcing large amounts of repainting.

See http://code.google.com/p/chromium/issues/detail?id=112009 for more details.
Comment 1 David Reveman 2012-02-07 12:46:55 PST
Created attachment 125902 [details]
Patch
Comment 2 Vangelis Kokkevis 2012-02-07 12:53:42 PST
Comment on attachment 125902 [details]
Patch

Looks good. Thanks!
Comment 3 James Robinson 2012-02-07 13:03:32 PST
Comment on attachment 125902 [details]
Patch

Looks good to me too, set r? cq? if you're ready to land this.
Comment 4 David Reveman 2012-02-07 13:32:10 PST
Created attachment 125915 [details]
Patch
Comment 5 David Reveman 2012-02-07 13:34:20 PST
(In reply to comment #3)
> (From update of attachment 125902 [details])
> Looks good to me too, set r? cq? if you're ready to land this.

New patch is ready to land. The updated patch just adds another check to the unit test to make sure we don't regress again.
Comment 6 David Reveman 2012-02-07 15:03:24 PST
*** Bug 77375 has been marked as a duplicate of this bug. ***
Comment 7 WebKit Review Bot 2012-02-07 17:03:23 PST
Comment on attachment 125915 [details]
Patch

Clearing flags on attachment: 125915

Committed r107014: <http://trac.webkit.org/changeset/107014>
Comment 8 WebKit Review Bot 2012-02-07 17:03:30 PST
All reviewed patches have been landed.  Closing bug.