Bug 76352

Summary: CSSCanvasValue can't be renamed, enforce this at compile-time.
Product: WebKit Reporter: Andreas Kling <kling>
Component: CSSAssignee: Andreas Kling <kling>
Status: RESOLVED FIXED    
Severity: Normal CC: macpherson, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch koivisto: review+

Description Andreas Kling 2012-01-15 18:05:59 PST
Instead of having CSSCanvasValue::setName(), the constructor should take the name as an argument.
Comment 1 Andreas Kling 2012-01-15 18:09:48 PST
Created attachment 122578 [details]
Patch
Comment 2 Antti Koivisto 2012-01-16 03:56:24 PST
Comment on attachment 122578 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=122578&action=review

> Source/WebCore/css/CSSParser.cpp:6454
>      CSSParserValue* a = args->current();
>      if (!a || a->unit != CSSPrimitiveValue::CSS_IDENT)

Maybe use a more descriptive name than 'a' since you are here.

> Source/WebCore/css/CSSParser.cpp:6457
> -    canvas = result;
> +
> +    canvas = CSSCanvasValue::create(a->string);

I wouldn't add an empty line here.
Comment 3 Andreas Kling 2012-01-16 05:00:50 PST
Committed r105056: <http://trac.webkit.org/changeset/105056>