Bug 76267

Summary: REGRESSION(r104905): This patch broke tests in the GTK 64bit Debug bot (Requested by msanchez on #webkit).
Product: WebKit Reporter: WebKit Review Bot <webkit.review.bot>
Component: New BugsAssignee: WebKit Review Bot <webkit.review.bot>
Status: RESOLVED FIXED    
Severity: Normal CC: mario, mrobinson
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 76069    
Attachments:
Description Flags
ROLLOUT of r104905 webkit.review.bot: commit-queue-

Description WebKit Review Bot 2012-01-13 05:05:54 PST
http://trac.webkit.org/changeset/104905 broke the build:
This patch broke tests in the GTK 64bit Debug bot (Requested by msanchez on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2012-01-13 05:06:24 PST
Created attachment 122413 [details]
ROLLOUT of r104905

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 WebKit Review Bot 2012-01-13 05:19:25 PST
Comment on attachment 122413 [details]
ROLLOUT of r104905

Rejecting attachment 122413 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '-..." exit_code: 2

Last 500 characters of output:
ILED at 75.
Hunk #5 FAILED at 85.
4 out of 5 hunks FAILED -- saving rejects to file Source/WebCore/html/HTMLDetailsElement.cpp.rej
patching file Source/WebKit/gtk/tests/testatk.c
patching file LayoutTests/ChangeLog
Hunk #1 succeeded at 1 with fuzz 3.
patching file LayoutTests/fast/dom/shadow/shadow-contents-select-expected.html
patching file LayoutTests/fast/dom/shadow/shadow-contents-select.html

Failed to run "[u'/mnt/git/webkit-commit-queue/Tools/Scripts/svn-apply', u'--force']" exit_code: 1

Full output: http://queues.webkit.org/results/11152539
Comment 3 Mario Sanchez Prada 2012-01-13 05:42:58 PST
I don't know what was wrong with the sheriffbot (looks like it created a bad rollout patch), so I manually created the rollout patch and pushed it.

Committed: http://trac.webkit.org/changeset/104922