Bug 75204

Summary: Change CSS canvas code that does HashMap get/set to use the more efficient add idiom
Product: WebKit Reporter: Darin Adler <darin>
Component: CSSAssignee: Darin Adler <darin>
Status: RESOLVED FIXED    
Severity: Normal CC: webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 72477    
Attachments:
Description Flags
Patch none

Description Darin Adler 2011-12-25 09:08:51 PST
Change CSS canvas code that does HashMap get/set to use the more efficient add idiom
Comment 1 Darin Adler 2011-12-25 09:10:10 PST
Created attachment 120511 [details]
Patch
Comment 2 Darin Adler 2011-12-25 09:10:58 PST
While working on bug 72477, I stumbled on this easy-to-improve call site.
Comment 3 mitz 2011-12-25 09:14:16 PST
Comment on attachment 120511 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=120511&action=review

> Source/WebCore/ChangeLog:9
> +        (WebCore::Document::getCSSCanvasContext): Change local variable name of element to

Did you mean “of result”?
Comment 4 Darin Adler 2011-12-25 09:21:12 PST
Comment on attachment 120511 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=120511&action=review

>> Source/WebCore/ChangeLog:9
>> +        (WebCore::Document::getCSSCanvasContext): Change local variable name of element to
> 
> Did you mean “of result”?

Sorry I was unclear. But I meant of element as in "of the element", the variable has always held an element, it was just named result.
Comment 5 WebKit Review Bot 2011-12-25 11:03:32 PST
Comment on attachment 120511 [details]
Patch

Clearing flags on attachment: 120511

Committed r103671: <http://trac.webkit.org/changeset/103671>
Comment 6 WebKit Review Bot 2011-12-25 11:03:36 PST
All reviewed patches have been landed.  Closing bug.