Bug 74356

Summary: REGRESSION(r102357): respondToUnappliedEditing exits early for CreateLinkCommand
Product: WebKit Reporter: Ryosuke Niwa <rniwa>
Component: HTML EditingAssignee: Ryosuke Niwa <rniwa>
Status: RESOLVED FIXED    
Severity: Normal CC: adele, darin, enrica, jiapu.mail
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
fixes the bug
none
Reveted orthogonal Editor.cpp change enrica: review+

Description Ryosuke Niwa 2011-12-12 15:12:39 PST
It appears that r102357 regressed Lion autocorrection panel. After r102357, respondToUnappliedEditing always exits early even when unapplying CreateLinkCommand since EditCommandComposition's isCreateLinkCommand return false.
Comment 1 Ryosuke Niwa 2011-12-12 16:16:43 PST
Is there some manual test / DRT test you can run on Lion for this? Unfortunately, I don't have access to Lion machines and I'm fixing this in blind.
Comment 2 Ryosuke Niwa 2011-12-12 16:27:09 PST
Created attachment 118901 [details]
fixes the bug
Comment 3 Ryosuke Niwa 2011-12-12 16:28:29 PST
Comment on attachment 118901 [details]
fixes the bug

Oops, this patch has some random Editor.cpp change :(
Comment 4 Ryosuke Niwa 2011-12-12 16:46:52 PST
Created attachment 118907 [details]
Reveted orthogonal Editor.cpp change
Comment 5 Enrica Casucci 2011-12-12 16:53:28 PST
Comment on attachment 118907 [details]
Reveted orthogonal Editor.cpp change

Looks fine to me.
Comment 6 Ryosuke Niwa 2011-12-12 16:59:41 PST
Committed r102643: <http://trac.webkit.org/changeset/102643>
Comment 7 Ryosuke Niwa 2011-12-12 17:07:34 PST
Thanks for the review. I just wish we could add a test for this (or that we already had one).