Bug 72652

Summary: REGRESSION (NRWT): NRWT always reports "1 unique leaks found" even when there are more than 1 unique leaks
Product: WebKit Reporter: Adam Roben (:aroben) <aroben>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, eric, ojan, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Make NRWT consider all lines of output from parse-malloc-history, not just the first darin: review+

Description Adam Roben (:aroben) 2011-11-17 14:04:31 PST
http://build.webkit.org/builders/Lion%20Intel%20Leaks/builds/175 says:

361 total leaks found for a total of 66,992 bytes! 1 unique leaks found!

But there are more than 1 unique leaks. Seems like a bug in NRWT.
Comment 1 Eric Seidel (no email) 2011-11-17 14:07:51 PST
:(  I swear I've seen it say other numbers.  Could this have been from your unquoting change earlier today?
Comment 2 Adam Roben (:aroben) 2011-11-18 08:11:47 PST
(In reply to comment #1)
> Could this have been from your unquoting change earlier today?

This was happening long before that change:

http://build.webkit.org/builders/Lion%20Intel%20Leaks/builds/114

"8676 total leaks found for a total of 1,856,864 bytes! 1 unique leaks found!"
Comment 3 Adam Roben (:aroben) 2011-11-18 13:37:14 PST
Created attachment 115862 [details]
Make NRWT consider all lines of output from parse-malloc-history, not just the first
Comment 4 WebKit Review Bot 2011-11-18 13:39:44 PST
Attachment 115862 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Tools/ChangeLog', u'Tools/Scripts/webkitpy..." exit_code: 1

Tools/Scripts/webkitpy/layout_tests/port/leakdetector_unittest.py:133:  trailing whitespace  [pep8/W291] [5]
Total errors found: 1 in 3 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Adam Roben (:aroben) 2011-11-18 13:49:32 PST
Comment on attachment 115862 [details]
Make NRWT consider all lines of output from parse-malloc-history, not just the first

View in context: https://bugs.webkit.org/attachment.cgi?id=115862&action=review

>> Tools/Scripts/webkitpy/layout_tests/port/leakdetector_unittest.py:133
>> +147 calls for 9,408 bytes: _CFRuntimeCreateInstance | _ZN3WTF24StringWrapperCFAllocatorL8allocateElmPv StringImplCF.cpp:67 | WTF::fastMalloc(unsigned long) FastMalloc.cpp:268 | malloc | malloc_zone_malloc 
> 
> trailing whitespace  [pep8/W291] [5]

Too bad! That's what parse-malloc-history gives us.
Comment 6 Adam Roben (:aroben) 2011-11-21 07:16:01 PST
Committed r100912: <http://trac.webkit.org/changeset/100912>
Comment 7 Adam Roben (:aroben) 2011-11-21 10:34:58 PST
Seems to be working: http://build.webkit.org/builders/Lion%20Intel%20Leaks/builds/228/steps/layout-test

"1293 total leaks found for a total of 156,416 bytes! 90 unique leaks found! 15 failures 6 flakes 6 missing results"
Comment 8 Eric Seidel (no email) 2011-11-21 11:11:24 PST
Thanks adam.