Bug 72477

Summary: Specialize HashTraits for RefPtr to use a raw pointer as "peek type" to reduce reference count churn
Product: WebKit Reporter: Darin Adler <darin>
Component: Web Template FrameworkAssignee: Darin Adler <darin>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: cmarcelo
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on: 72474, 75204    
Bug Blocks:    

Description Darin Adler 2011-11-15 23:47:02 PST
Functions like get() on a HashMap with a RefPtr as a value should return raw pointers, not RefPtr. Making this change will require changing all the client code to remove unnecessary calls to get().
Comment 1 Darin Adler 2013-05-26 18:10:55 PDT

*** This bug has been marked as a duplicate of bug 115646 ***