Bug 70120

Summary: [Chromium] Pass MessagePortArray to SerializedScriptValue::serialize/deserialize
Product: WebKit Reporter: Dmitry Lomov <dslomov>
Component: WebCore Misc.Assignee: Dmitry Lomov <dslomov>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, kbr, levin, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 65209    
Attachments:
Description Flags
Fix
levin: review+, levin: commit-queue-
CR feedback none

Dmitry Lomov
Reported 2011-10-14 11:23:16 PDT
SerializedScriptValue needs to know the message ports being sent with the message to implement trasfer
Attachments
Fix (20.15 KB, patch)
2011-10-14 11:27 PDT, Dmitry Lomov
levin: review+
levin: commit-queue-
CR feedback (20.10 KB, patch)
2011-10-14 12:02 PDT, Dmitry Lomov
no flags
Dmitry Lomov
Comment 1 2011-10-14 11:27:54 PDT
David Levin
Comment 2 2011-10-14 11:46:55 PDT
Comment on attachment 111033 [details] Fix View in context: https://bugs.webkit.org/attachment.cgi?id=111033&action=review Please fix these small issues and commit away! > Source/WebCore/bindings/v8/SerializedScriptValue.cpp:1923 > +SerializedScriptValue::SerializedScriptValue(v8::Handle<v8::Value> value, MessagePortArray* messagePorts, bool& didThrow) Omit the var name (since it isn't used) or else you'll get compile errors on some platforms. > Source/WebCore/bindings/v8/SerializedScriptValue.cpp:1968 > +v8::Handle<v8::Value> SerializedScriptValue::deserialize(MessagePortArray* messagePorts) Ditto. > Source/WebCore/bindings/v8/SerializedScriptValue.h:81 > + SerializedScriptValue(v8::Handle<v8::Value>, MessagePortArray* messagePorts, bool& didThrow); Omit the variable name since it adds no information. > Source/WebCore/bindings/v8/custom/V8DOMWindowCustom.cpp:356 > + return handlePostMessageCallback(args, false); We prefer enums in WebKit when the value passed in is just true/false to make the call site more readable. > Source/WebCore/bindings/v8/custom/V8DedicatedWorkerContextCustom.cpp:57 > + ExceptionCode ec = 0; Indentation is off.
David Levin
Comment 3 2011-10-14 11:47:35 PDT
(In reply to comment #2) > (From update of attachment 111033 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=111033&action=review > > > Source/WebCore/bindings/v8/custom/V8DOMWindowCustom.cpp:356 > > + return handlePostMessageCallback(args, false); > > We prefer enums in WebKit when the value passed in is just true/false to make the call site more readable. Note this one is true in several places.
David Levin
Comment 4 2011-10-14 11:50:22 PDT
OK ignore the enum comment since the uses are in file.
Dmitry Lomov
Comment 5 2011-10-14 12:02:25 PDT
Created attachment 111042 [details] CR feedback
WebKit Review Bot
Comment 6 2011-10-14 15:12:09 PDT
Comment on attachment 111042 [details] CR feedback Clearing flags on attachment: 111042 Committed r97516: <http://trac.webkit.org/changeset/97516>
WebKit Review Bot
Comment 7 2011-10-14 15:12:14 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.