Bug 69933

Summary: [Qt][GTK] Assertion fail in CSSPrimitiveValue ctor
Product: WebKit Reporter: Balazs Kelemen <kbalazs>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED WORKSFORME    
Severity: Normal CC: koivisto, menard, ossy, pnormand, zarvai
Priority: P2 Keywords: LayoutTestFailure, Qt, QtTriaged
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 79668    

Description Balazs Kelemen 2011-10-12 08:42:07 PDT
ASSERTION FAILED: isfinite(num)
../../../Source/WebCore/css/CSSPrimitiveValue.cpp(184) : WebCore::CSSPrimitiveValue::CSSPrimitiveValue(double, WebCore::CSSPrimitiveValue::UnitTypes)

Full log:
http://build.webkit.sed.hu/results/x86-32%20Linux%20Qt%20Debug/r97259%20(18924)/fast/borders/inline-mask-overlay-image-outset-crash-log.txt

The culprit might be http://trac.webkit.org/changeset/97248
Comment 1 Antti Koivisto 2011-10-12 10:47:56 PDT
It is unlikely that http://trac.webkit.org/changeset/97248 has anything to do with this as it only concerns code that runs well after any CSSPrimitiveValue construction.
Comment 2 Csaba Osztrogon√°c 2011-10-13 00:08:24 PDT
As far as I remember it is a flakey assertion, we should check it in the buildbot history.
Comment 3 Philippe Normand 2011-11-18 06:50:23 PST
*** Bug 69000 has been marked as a duplicate of this bug. ***
Comment 4 Philippe Normand 2011-11-18 06:50:37 PST
*** Bug 72716 has been marked as a duplicate of this bug. ***