Bug 69840

Summary: Fix build with GLib 2.31
Product: WebKit Reporter: Tomeu Vizoso <tomeu.vizoso>
Component: New BugsAssignee: Gustavo Noronha (kov) <gns>
Status: RESOLVED FIXED    
Severity: Normal CC: gns, levin+threading, mrobinson, silouck, webkit.review.bot, xan.lopez
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch none

Description Tomeu Vizoso 2011-10-11 07:43:52 PDT
Fix build with GLib 2.31
Comment 1 Tomeu Vizoso 2011-10-11 07:45:30 PDT
Created attachment 110514 [details]
Patch
Comment 2 Gyuyoung Kim 2011-10-11 08:02:29 PDT
Comment on attachment 110514 [details]
Patch

Attachment 110514 [details] did not pass efl-ews (efl):
Output: http://queues.webkit.org/results/10028526
Comment 3 Gustavo Noronha (kov) 2011-10-11 08:08:58 PDT
Comment on attachment 110514 [details]
Patch

This partially defeats the purpose of the GTypedefs.h header, which was intended mainly to avoid including glib.h and a few other headers, and is lacking a ChangeLog entry (I know, it sucks) which you can generate with ./Tools/Scripts/prepare-ChangeLog.

I see two ways going forward:

1 - give up on avoiding including glib (and then removing all of the relevant typedefs)
2 - stop using GMutex; there was some discussion in webkit-dev about dropping non-pthread/non-win32 implementations, I wonder if we could just go that route?
Comment 4 Gustavo Noronha (kov) 2011-10-12 07:24:29 PDT
Created attachment 110683 [details]
Patch
Comment 5 Gustavo Noronha (kov) 2011-10-12 07:26:15 PDT
The only usage of GMutex/GCond remaining after this is inside the gstreamer backend and does not use the GOwnPtr support. We can make it use wtf threading in a follow up.
Comment 6 Martin Robinson 2011-10-12 08:40:58 PDT
Comment on attachment 110683 [details]
Patch

This breaks Win32 GTK+, but if possible, it should switch to ThreadingWin.cpp instead.
Comment 7 Gustavo Noronha (kov) 2011-10-12 09:54:42 PDT
Comment on attachment 110683 [details]
Patch

Clearing flags on attachment: 110683

Committed r97269: <http://trac.webkit.org/changeset/97269>
Comment 8 Gustavo Noronha (kov) 2011-10-12 09:54:50 PDT
All reviewed patches have been landed.  Closing bug.
Comment 9 Yael 2012-05-26 16:40:04 PDT
*** Bug 72085 has been marked as a duplicate of this bug. ***