Bug 69788

Summary: Improve output of run-api-tests to make time-outs more obvious
Product: WebKit Reporter: Simon Fraser (smfr) <simon.fraser>
Component: Tools / TestsAssignee: Simon Fraser (smfr) <simon.fraser>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, aroben, eric, simon.fraser
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 69942    
Bug Blocks:    
Attachments:
Description Flags
Patch aroben: review+

Description Simon Fraser (smfr) 2011-10-10 14:52:57 PDT
Right now, some api tests are timing out; see http://build.webkit.org/builders/Lion%20Intel%20Release%20%28WebKit2%20Tests%29/builds/1293

However, unless you know what to look for, it's very hard to determine that this is the cause of the failures. The script output should be improved to make the failures more obvious.
Comment 1 Simon Fraser (smfr) 2011-10-12 11:17:20 PDT
Created attachment 110709 [details]
Patch
Comment 2 Adam Roben (:aroben) 2011-10-12 11:19:16 PDT
Comment on attachment 110709 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=110709&action=review

> Tools/Scripts/run-api-tests:133
> +        for my $test (@testsTimedOut) {

I think you meant if (@testsTimedOut).

> Tools/Scripts/run-api-tests:214
> +    if ($result) {
> +        push @testsFailed, $suite.".".$test;
> +    }
>      if ($timedOut) {
> +        push @testsTimedOut, $suite.".".$test;

I think "$suite.$test" would be a little clearer.
Comment 3 Simon Fraser (smfr) 2011-10-18 16:18:56 PDT
http://trac.webkit.org/changeset/97277