Bug 69711

Summary: Remove 32 bit restrictions in DFG JIT
Product: WebKit Reporter: Yuqiang Xian <yuqiang.xian>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: barraclough, fpizlo, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
the patch none

Description Yuqiang Xian 2011-10-08 18:00:05 PDT
op_call/op_construct support was disabled for 32 bit DFG JIT because there was regression in javascriptcore tests. Now the bugs are fixed and there should be no regression. This makes 32 bit DFG have the same capability as 64 bit DFG, and improves the coverage.
Comment 1 Yuqiang Xian 2011-10-08 18:03:39 PDT
Created attachment 110286 [details]
the patch
Comment 2 Filip Pizlo 2011-10-08 23:49:22 PDT
Comment on attachment 110286 [details]
the patch

I'm happy with this.
Comment 3 WebKit Review Bot 2011-10-09 01:07:54 PDT
Comment on attachment 110286 [details]
the patch

Clearing flags on attachment: 110286

Committed r97022: <http://trac.webkit.org/changeset/97022>
Comment 4 WebKit Review Bot 2011-10-09 01:07:58 PDT
All reviewed patches have been landed.  Closing bug.