Bug 68544

Summary: [Qt] Remote Web Inspector's Script Panel does not work Qt webkit 2.2 RC1
Product: WebKit Reporter: Sriram Neelakandan <sriram.neelakandan>
Component: Web Inspector (Deprecated)Assignee: Nobody <webkit-unassigned>
Status: RESOLVED LATER    
Severity: Normal CC: ademar, edufelipe
Priority: P3    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 68616    

Description Sriram Neelakandan 2011-09-21 10:41:03 PDT
1. Enable remote inspector using -remote-inspector-port  option while launching QtTestBrowser
2. Now try to Launch Remote Web Inspector for the page opened by QtTestBrowser
3. Most functions of Remote Web Inspector works except for Script Panel; which remains disabled even after clicking on "Enable Debugger" button

The fix lies in the following InspectorFrontendStub changeset in Webkit Trunk
http://trac.webkit.org/changeset/87744

Qt-webkit-2.2 branch still does not have this changeset cherry picked.
Comment 1 Ademar Reis 2011-09-21 11:34:41 PDT
(In reply to comment #0)
> 1. Enable remote inspector using -remote-inspector-port  option while launching QtTestBrowser
> 2. Now try to Launch Remote Web Inspector for the page opened by QtTestBrowser
> 3. Most functions of Remote Web Inspector works except for Script Panel; which remains disabled even after clicking on "Enable Debugger" button
> 

Sorry for the stupid question, but how can I perform step 2? I have never used the remote web inspector and have no idea how to enable or use it (and nobody from IRC right now either).

> The fix lies in the following InspectorFrontendStub changeset in Webkit Trunk
> http://trac.webkit.org/changeset/87744
> 
> Qt-webkit-2.2 branch still does not have this changeset cherry picked.

If this small commit is all that's needed to make it work properly, then the fix is a candidate for a future patch-level release (e.g.: QtWebKit-2.2.1). But first I have to figure out how to test it. :)
Comment 2 Sriram Neelakandan 2011-09-21 21:05:03 PDT
(In reply to comment #1)
> Sorry for the stupid question, but how can I perform step 2? I have never used the remote web inspector and have no idea how to enable or use it (and nobody from IRC right now either).

This will do it

1. ./QtTestBrowser -remote-inspector-port 9292
2. Load a page say www.google.com
3. Now use the latest version of chrome (websockets enabled version) and then connect to 127.0.0.1:9292/ 
4. Click on the Link displayed (google.com) to launch the Remote Inspector for that page



> If this small commit is all that's needed to make it work properly, then the fix is a candidate for a future patch-level release (e.g.: QtWebKit-2.2.1). But first I have to figure out how to test it. :)

Yes its just a simple 2 line function fix... 

But the problem is, remote JS debugging for mobile developers will not be possible without this simple fix!
Comment 3 Ademar Reis 2011-09-22 07:36:57 PDT
Problem tested and reproduced in 2.2, fix indeed works. I added it to the internal branch, It'll be part of our next minor update (2.2.1).
Comment 4 Sriram Neelakandan 2011-09-22 21:18:14 PDT
Thanks.

>It'll be part of our next minor update (2.2.1).

Is there a master bug for 2.2.1 ? then i shall mark the dependency list or create one ?
Comment 5 Sriram Neelakandan 2011-09-22 21:19:52 PDT
> 
> Is there a master bug for 2.2.1 ? 
Sorry, my bad Did not see #68616