Bug 68275

Summary: [CSS Regions] Text does not reflow on a vertical resize
Product: WebKit Reporter: Alan Stearns <stearns>
Component: Layout and RenderingAssignee: Alexandru Chiculita <achicu>
Status: RESOLVED WORKSFORME    
Severity: Normal CC: donggwan.kim, hyatt, mibalan, mihnea, simon.fraser, webkit-bug-importer, WebkitBugTracker
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 57312    
Attachments:
Description Flags
Testcase
none
updated testcase none

Description Alan Stearns 2011-09-16 13:24:27 PDT
Created attachment 107715 [details]
Testcase

If text is displayed in regions with a percentage height, resizing the window (and therefore changing the region size) does not cause the text to reflow.

I've tried to come up with a LayoutTest for this, but changing region height or the height of the container with relative-height regions in javascript does cause reflow. I've only seen the problem with a manual window resize.
Comment 1 Radar WebKit Bug Importer 2011-12-08 15:40:40 PST
<rdar://problem/10552272>
Comment 2 Alan Stearns 2011-12-08 15:46:46 PST
Created attachment 118480 [details]
updated testcase
Comment 3 Mihnea Ovidenie 2012-12-27 06:22:52 PST
Hi Alan, would you mind testing it again? It works for me in the latest WebKit nightly.
Comment 4 Alan Stearns 2013-01-02 14:03:08 PST
I can't reproduce the problem in the current build, either. Closing the bug.