Bug 65605

Summary: [Qt]REGRESSION(r92224): It made editing/text-iterator/basic-iteration.html timeout
Product: WebKit Reporter: Csaba Osztrogonác <ossy>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Critical CC: barraclough, fpizlo, loki, oliver, ossy, zherczeg
Priority: P1 Keywords: Qt, QtTriaged
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 65438, 79666, 79668    

Description Csaba Osztrogonác 2011-08-03 04:17:18 PDT
r92224 made editing/text-iterator/basic-iteration.html timeout on Qt in debug mode. (32 and 64 bit too)
Comment 1 Csaba Osztrogonác 2011-08-03 05:14:19 PDT
failing tests are skipped by https://trac.webkit.org/changeset/92272 to make our debug bots green.
Comment 2 Filip Pizlo 2011-08-03 13:39:22 PDT
(In reply to comment #1)
> failing tests are skipped by https://trac.webkit.org/changeset/92272 to make our debug bots green.

I'm looking into this.  Hopefully I can get this test passing on Qt soon.
Comment 3 Filip Pizlo 2011-08-04 15:04:25 PDT
I cannot reproduce this on Ubuntu 11.04, 32-bit, Qt 4.7.2, WebKit tip of tree.  editing/text-iterator/basic-iteration.html passes just fine and does not hang.

Can you supply more information about how to make this bug happen?
Comment 4 Csaba Osztrogonác 2012-05-17 05:26:53 PDT
It seems it passes now, so I unskipped it - r117434.