Bug 64419

Summary: Remove hack that forcefully prevents scripts from running in shadow SVG
Product: WebKit Reporter: James Simonsen <simonjam>
Component: New BugsAssignee: James Simonsen <simonjam>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: ddkilzer, schenney, tonyg, webkit.review.bot, zimmermann
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 64776, 64778, 64779, 64781    
Bug Blocks:    
Attachments:
Description Flags
Patch
none
Patch for landing none

Description James Simonsen 2011-07-12 18:39:53 PDT
Remove hack that forcefully prevents scripts from running in shadow SVG
Comment 1 James Simonsen 2011-07-12 18:47:32 PDT
Created attachment 100604 [details]
Patch
Comment 2 James Simonsen 2011-07-12 18:48:50 PDT
This should undo r88549 (except for the tests).
Comment 3 Tony Gentilcore 2011-07-13 03:04:25 PDT
Comment on attachment 100604 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=100604&action=review

> Source/WebCore/ChangeLog:12
> +        No new tests. Passed existing tests. No new functionality.

I don't understand. Shouldn't there be an expectations update if we are now passing an existing test?
Comment 4 James Simonsen 2011-07-13 16:47:56 PDT
(In reply to comment #3)
> (From update of attachment 100604 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=100604&action=review
> 
> > Source/WebCore/ChangeLog:12
> > +        No new tests. Passed existing tests. No new functionality.
> 
> I don't understand. Shouldn't there be an expectations update if we are now passing an existing test?

I mean that I ran all of the tests and they still pass as they did before the change. Because r88549 went in, the code I'm removing should never trigger. I'll try to reword that when I commit.
Comment 5 James Simonsen 2011-07-13 16:57:11 PDT
Created attachment 100731 [details]
Patch for landing
Comment 6 WebKit Review Bot 2011-07-13 19:05:17 PDT
Comment on attachment 100731 [details]
Patch for landing

Clearing flags on attachment: 100731

Committed r90970: <http://trac.webkit.org/changeset/90970>
Comment 7 WebKit Review Bot 2011-07-13 19:05:24 PDT
All reviewed patches have been landed.  Closing bug.
Comment 8 James Simonsen 2011-07-18 20:11:55 PDT
This hack was restored because it protects from two other bugs.
Comment 9 Nikolas Zimmermann 2012-02-25 02:45:43 PST
Bug 78902 also contains this change. Bug is fixed, now that SVG <use> impl uses ShadowRoot.

*** This bug has been marked as a duplicate of bug 78902 ***