Bug 63628

Summary: generate-webkitversion.pl should not "use Switch"
Product: WebKit Reporter: Leandro Pereira <leandro>
Component: New BugsAssignee: Leandro Pereira <leandro>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, ademar, benjamin, hausmann, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Leandro Pereira 2011-06-29 07:40:47 PDT
generate-webkitversion.pl should not "use Switch"
Comment 1 Leandro Pereira 2011-06-29 07:42:40 PDT
Created attachment 99089 [details]
Patch
Comment 2 Leandro Pereira 2011-06-29 07:48:04 PDT
Switch.pm isn't available in current Perl versions, so generate-webkitversions.pl 
 fails with this error message:

Can't locate Switch.pm in @INC (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at /home/leandro/git/webkit/Source/WebKit/scripts/generate-webkitversion.pl line 42.

Since no switch statement is used, it is safe to remove it from the script. The attached patch does that.
Comment 3 Leandro Pereira 2011-06-29 07:50:11 PDT
CCing Simon Hausmann and Adam Barth, who recently changed this file.
Comment 4 Adam Barth 2011-06-29 08:33:30 PDT
Comment on attachment 99089 [details]
Patch

I wish I knew enough about Perl to review this patch.
Comment 5 Simon Hausmann 2011-06-30 00:32:26 PDT
Comment on attachment 99089 [details]
Patch

r=me
Comment 6 WebKit Review Bot 2011-06-30 00:42:24 PDT
Comment on attachment 99089 [details]
Patch

Clearing flags on attachment: 99089

Committed r90093: <http://trac.webkit.org/changeset/90093>
Comment 7 WebKit Review Bot 2011-06-30 00:42:29 PDT
All reviewed patches have been landed.  Closing bug.
Comment 8 Ademar Reis 2011-07-18 10:15:29 PDT
Revision r90093 cherry-picked into qtwebkit-2.2 with commit 3a4bda7 <http://gitorious.org/webkit/qtwebkit/commit/3a4bda7>