Bug 63537

Summary: Skip cache validation on back with HTTPS.
Product: WebKit Reporter: Adam Langley <agl>
Component: WebCore Misc.Assignee: Adam Barth <abarth>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, mjs, tony, webkit.review.bot
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
patch
none
Patch for landing
none
Patch for landing none

Description Adam Langley 2011-06-28 07:52:06 PDT
For back navigations over HTTP, WebKit sets a flag to use cached data
irrespective of whether it has expired. However, this isn't currently
done for HTTPS.

The logic in question was added in
https://bugs.webkit.org/show_bug.cgi?id=33993 and appears to have been
precautionary. However, both Firefox and IE will use this back
navigation trick for HTTPS as well and so we should probably behave
likewise.
Comment 1 Adam Langley 2011-06-28 07:53:12 PDT
Created attachment 98921 [details]
patch
Comment 2 Tony Chang 2011-06-28 11:16:41 PDT
Can we write a layout test for this?
Comment 3 Adam Barth 2011-06-28 14:02:17 PDT
Comment on attachment 98921 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=98921&action=review

> Source/WebCore/ChangeLog:17
> +        https://bugs.webkit.org/show_bug.cgi?id=63537

This bug link needs to be the first one in the ChangeLog or else the tools will get confused.  Usually we put it right under the bug title.
Comment 4 Adam Barth 2011-06-28 16:38:17 PDT
Comment on attachment 98921 [details]
patch

I'll take a crack at writing a test.  Thanks agl.
Comment 5 Adam Barth 2011-06-28 16:48:00 PDT
I'm not sure if we have a good way to test this patch.  The problem is that dumpResourceLoadCallbacks doesn't include the cache policy.
Comment 6 Adam Barth 2011-06-28 16:48:49 PDT
Created attachment 99000 [details]
Patch for landing
Comment 7 Adam Barth 2011-06-28 16:49:15 PDT
If someone has an idea for a good way to test this patch, please feel free to re-open this bug and assign it to me.
Comment 8 Tony Chang 2011-06-28 17:01:30 PDT
LayoutTests/http/tests/cache/history-only-cached-subresource-loads.html seems to load a page in a new window with a random number.  When pressing back, it checks to see if the random number has changed.
Comment 9 Adam Barth 2011-06-28 17:08:54 PDT
Great.  Thanks.
Comment 10 Adam Barth 2011-06-28 17:38:36 PDT
Created attachment 99008 [details]
Patch for landing
Comment 11 WebKit Review Bot 2011-06-28 18:04:08 PDT
Comment on attachment 99008 [details]
Patch for landing

Clearing flags on attachment: 99008

Committed r89982: <http://trac.webkit.org/changeset/89982>
Comment 12 WebKit Review Bot 2011-06-28 18:04:13 PDT
All reviewed patches have been landed.  Closing bug.
Comment 13 David Kilzer (:ddkilzer) 2011-11-08 08:05:40 PST
<rdar://problem/10412387>