Bug 63459

Summary: [Qt][WK2] Random crashes in fast/frames/ tests
Product: WebKit Reporter: Chang Shu <cshu>
Component: WebKit2Assignee: Chang Shu <cshu>
Status: RESOLVED FIXED    
Severity: Normal CC: darin, kenneth, kimmo.t.kinnunen, kling, laszlo.gombos, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: Linux   
Attachments:
Description Flags
patch
none
patch 2 none

Description Chang Shu 2011-06-27 08:45:15 PDT
Random crashes have been observed in running layout tests under /fast/frames, such as
fast/frames/negative-remaining-length-crash.html
Comment 1 Chang Shu 2011-06-27 08:59:42 PDT
Created attachment 98736 [details]
patch
Comment 2 Chang Shu 2011-06-28 11:01:41 PDT
Created attachment 98941 [details]
patch 2

Use QMetaObject::invokeMethod as suggested by kling. The code is cleaner.
Comment 3 Andreas Kling 2011-06-28 11:07:35 PDT
Comment on attachment 98941 [details]
patch 2

r=me
Comment 4 Chang Shu 2011-06-28 12:01:21 PDT
*** Bug 63006 has been marked as a duplicate of this bug. ***
Comment 5 WebKit Review Bot 2011-06-28 12:01:41 PDT
Comment on attachment 98941 [details]
patch 2

Clearing flags on attachment: 98941

Committed r89947: <http://trac.webkit.org/changeset/89947>
Comment 6 WebKit Review Bot 2011-06-28 12:01:46 PDT
All reviewed patches have been landed.  Closing bug.